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Microsoft Excel Fundamentals

	Startup With Microsoft Excel

	


  

	Introduction

	


Microsoft Excel is a spreadsheet application. That is, it is used to create and manage lists of information. To effectively handle list-related assignments, this environment provides many more features than simply dealing with lists. 

	Starting Microsoft Excel

	


To use Microsoft Excel, there are various ways you can start it:

· As a regular Microsoft Windows application, to use Microsoft Excel, you can click Start -> (All) Programs -> Microsoft Office -> Microsoft Office Excel 2003

· You can also create a shortcut on the desktop, in Windows Explorer, or in My Computer. To create a shortcut, you can click Start -> (All) Programs -> Microsoft Office, right-click and hold your right mouse on Microsoft Office Excel and drag (with the right mouse button) to the desktop. On the menu that appears, click Create Shortcut Here. Another technique you can use consists of opening My Computer, expanding the drive, the Program Files folder, the Microsoft Office folder, the Office11 folder, right-clicking Excel, clicking Create Shortcut, right-clicking the new shortcut and clicking Cut, right-click your desktop and click Paste.

· If you are using My Computer or Windows Explorer, you can open the Program Files folder, then Microsoft Office, then Office, and double-click Excel

· You can create an empty document on your desktop and use it to launch Microsoft Excel. To do that, you would right-click an empty area on the desktop, position the mouse on New -> Microsoft Office Excel Worksheet, type a name for the document, such as Time Sheet, and press Enter twice

· If you see a file in My Computer, Windows Explorer, My Network Places, Microsoft Outlook, or you receive a document by e-mail, you can launch Microsoft Excel by double-clicking the file or the attachment.

The classic way users launch Microsoft Excel is from the Start menu on the task bar. You can also start the application from a shortcut on the desktop. There are many ways you can create a shortcut on your desktop. To create a Microsoft Excel shortcut on the desktop, do one of the following:

  

	Practical Learning: Starting Microsoft Excel

	


· To start Microsoft Excel, from the Taskbar, click
Start -> (All) Programs -> Microsoft Office -> Microsoft Office Excel
 
[image: image2]
  

	The Microsoft Excel Interface

	


Microsoft Excel is a classic computer application and easily recognizable if you have spent some time with other Microsoft Office applications. On top of the application, it displays a horizontal object called the title bar. 

On the left side of the title bar, there is a small picture called the application icon or the system icon. This icon allows you to minimize, maximize, restore, resize, move, close Microsoft Excel. To perform any of these actions, you would click the icon and this would display a menu:

[image: image3]
On the right side of the application icon, the name of the program, in this case, Microsoft Excel, displays. The application's name is followed by the file name; in this case Book1.

Microsoft Excel identifies each one of its documents with a name that starts with Book. Microsoft Excel is a Multiple Document Interface (MDI), which means you can open more that one document inside the application. Therefore, if you create or initialize more than one document in Microsoft Excel, subsequent documents would be called Book2, Book3, BookX.

The main menu of Microsoft Excel allows you to request various tasks. The File menu allows you to create either a new empty document or a document based on one of the templates that ship with the application. You can also use the File menu to save the current document, to close the current file, or to configure or initialize printing. The File menu allows you to perform other various actions that we will discover as we move on.

Besides the File menu, there are other menu items that allow you to do many other things. Just like any menu that is part of the operating system, there are four classic categories of menus in Microsoft Excel: 

· [image: image4]A sub-menu that is gray is temporarily disabled, which means it is not currently available. Some examples at this time are Edit -> Paste, Data -> Refresh Data. A menu in this state will not work, it is waiting for something else to happen, and then it will become enabled

· [image: image5]A sub-menu that stands by itself will perform a simple action, some of those actions even occur behind the scenes, sometimes giving you the impression that nothing happened when you clicked them. Examples of such menus include File -> Save, Edit -> Copy, etc (The File -> Save menu will behave like the next category if the document has not been saved yet)

· [image: image6]Menus in another category have three dots on their line. This type of menu indicates that it requires or expects an intermediary action such as calling a dialog box

· [image: image7]The last category of menus has a right pointing arrow. You don't need to click these menus. The arrow means that this menu item has a sub-menu. To access the sub-menu, you can just position your mouse on the item with arrow and you will have access to the sub-menu

Whether a menu falls under one of these categories or not, some menu items display a combination of buttons on their line, these are shortcuts. A shortcut is a key or a combination of keys that you press (simultaneously) to perform an action.

Whenever you have opened a menu by mistake or you simply want to get rid of it, you usually can click somewhere else, you can also click the same menu, or press Esc.

To perform a single key shortcut, you would press the corresponding key. To perform a combination key shortcut, you would press and hold the first key, then press the second key once. From now on, if you are asked to press Ctrl + O, this means press and hold Ctrl, press the letter O once, and then release Ctrl.

Since you already know that Microsoft Excel is an MDI, you can check how many documents are opened at this time, using the main menu.

Some shortcuts can be seen or checked on the main menu, some of the shortcuts are not obvious, some others are part of the operating system.

Under the menu bar, the Standard toolbar provides some of the most regularly used actions performed on the main menu. A toolbar provides the same actions you would perform from the main menu, only faster, so that instead of going through the menu to save a document, you can just use the Save button.

Since there are various buttons and sometimes they are unpredictable, to know what a particular button is used for, you can position your mouse on it. A small yellowish box would appear to let you know what that particular button is used for; that small box is called a tool tip:

[image: image8]
You can also use context sensitive help in some cases to get information about an item.

On the right side of the Standard toolbar, there is another toolbar called the Formatting toolbar 
This second toolbar offers some formatting features that we will use as we move on. Its buttons also provide tool tips. Besides other buttons, the Formatting toolbar is equipped with combo boxes, and each combo box can display an appropriate tool tip.

Under the toolbars, there is a white box displaying a name like A1 (it may not display A1...), that small box is called the Name Box:

[image: image9]
On the right side of the Name box, there is a gray box with an fx button. That fx button is called the Edit Formula button.

On the right side of the Edit Formula button is a long empty white box or section called the Formula Bar.

Under the Name Box and the Formula bar, you see the columns. The columns are labeled A, B, C, etc:

[image: image10]
There are 255 of columns.

On the left side of the main window, there are gray boxes called rows. Each row is labeled with a number, starting at 1 on top, then 2, and so on:

[image: image11]
The main area of Microsoft Excel is made of cells. A cell is the intersection of a column and a row:

[image: image12]
A cell is identified by its name and every cell has a name. By default, Microsoft Excel appends the name of a row to the name of a column to identify a cell. Therefore, the top-left cell is named A1. You can check the name of the cell in the Name Box. To see different cells names, find the cell that intersects a column and a row.

On the right side of the cells area, there is a vertical scroll bar that allows you to scroll up and down in case your document cannot display everything at a time:

[image: image13]
On the lower right section of the main window, there is a horizontal scroll bar that allows you to scroll left and right if your worksheet has more items than can be displayed all at once:

[image: image14]
Sometimes the horizontal scroll bar will appear too long or too narrow for you. If you want, you can narrow or enlarge it. To do this, click and drag the button on the left side of the horizontal scroll bar:

[image: image15]
On the left side of the horizontal scrollbar, there are the worksheet tabs:

[image: image16]
By default, Microsoft Excel provides three worksheets to start with. You can work with any of them and switch to another at any time by clicking its tab.

On the left side of the worksheet tabs, there are four navigation buttons:

[image: image17]
If you happen to use a lot of worksheets or the worksheet names are using a lot of space, which will result in some worksheets hidden under the horizontal scroll bar, you can use the navigation buttons to move from one worksheet to another.

Under the navigation buttons and the worksheet tabs, the Status Bar provides a lot of information about the job that is going on.

  

	[image: image18]Practical Learning: Using Cells

	


1. Click anywhere on the worksheet and type A
(It doesn't matter where you click and type)

2. Click another part of the worksheet and type 42XL
3. Click again another place on the worksheet type Fundamentals and press Enter

	The Zoom Settings

	


The zoom combo box on the Standard toolbar helps to increase or decrease the view items of the main area of Microsoft Excel. Although it doesn't affect the actual display of the characters sizes or cells contents, using the zoom setting can make the worksheet a little easier to read.

To change the zoom setting, you can click the arrow of the Zoom combo box and select one of the values in the list. On the other hand, you can click the zoom value itself, type an integer (natural number) like 128, and press Enter.

	[image: image19]Practical Learning: Control The Interface’s Zoom Settings

	


1. On the Standard toolbar, click the arrow of the Zoom combo box and select 200%
 
[image: image20]
2. Notice that the worksheet displays with everything big now

3. Click the 200% number on the Zoom combo box, type 145, and press Enter. Now the display is smaller than the previous setting.

4. Press Alt, v, z. That will call the Zoom dialog box

5. Click the text box right to Custom, delete its content, type 68, and press Enter. Now the display is even smaller.

6. On the main menu, click View -> Zoom...
 
[image: image21]
7. Click the 100% radio button and click OK 

	Microsoft Excel File Operations

	


  

	Saving a File

	


A Microsoft Excel file gets saved like any traditional Windows file. Two issues are important. Whenever you decide to save a file for the first time, you need to provide a file name and a location. The file name helps the computer identify that particular file and registers it.

A file name can consist of up to 255 characters, you can include spaces and dashes in a name. Although there are many characters you can use in a name (such as exclamation points, etc), try to avoid fancy names. Give your file a name that is easily recognizable, a little explicit. For example such names as Time Sheets, Employee's Time Sheets, GlobalEX First Invoice are explicit enough. Like any file of the Microsoft Windows operating systems, a Microsoft Excel file has an extension, which is .xls but you don't have to type it in the name.

The second important piece of information you should pay attention to when saving your file is the location. The location is the drive and/or the folder where the file will be saved. By default, Microsoft Excel saves its files in the My Documents folder. You can change that in the Save As dialog box. Just click the arrow of the Save In combo box and select the folder you want.

Microsoft Excel allows you to save its files in a type of your choice. To save a file in another format than the default Microsoft Excel file, from the Save As dialog box, click the arrow of the Save As Type combo box and select a format of your choice.

There are other things you can do in the Save As dialog box.

To save a file for the first time, you can click File on the main menu, then click Save (if the file has not been saved before, the File -> Save menu will call the Save As dialog box). You can also click the Save button [image: image22]on the Standard toolbar. You can as well press Ctrl + S. Other alternatives include pressing F12, Alt + F2, or Shift + F12.

[image: image23]
	[image: image24]Practical Learning: Saving a File

	


1. To save the current document, on the main menu, click File -> Save

2. Type Fundamentals
3. Click the Save button

	Saving under a Different Name and New Folder

	


You can save a file under a different name or in another location, this gives you the ability to work on a copy of the file while the original is intact.

There are two primary techniques you can use to get a file in two names or the same file in two locations. When the file is not being used by any application, in Windows Explorer (or in My Computer, or in My Network Places, locate the file, right-click it and choose Copy. To save the file in a different name, right-click in the same folder and choose Paste. The new file will be named Copy Of... You can keep that name or rename the new file with a different name (recommended). To save the file in a different location, right-click in the appropriate folder and click Paste; in this case, the file will keep its name.

In Microsoft Excel, you can use the Save As dialog box to save a file in a different name or save the file with the same name (or a different name) in another folder. The Save As dialog box also allows you to create a new folder while you are saving your file (you can even use this technique to create a folder from the application even if you are not saving it; all you have to do is create the folder, click OK to register the folder, and click Cancel on the Save As dialog box).

	[image: image25]Practical Learning: Save a File With Different Settings

	


1. To save this file using a different name, on the main menu, click File -> Save As...

2. Change the name of the file to Employment Application
3. On the toolbar of the Save As dialog box, click the Create New Folder button (if you have a hard time finding it, press Alt + 5

4. Type My Files and press Enter. The My Files folder should now display in the Save In combo box. If you clicked Cancel or pressed Esc now to dismiss the Save As dialog box, the computer would still keep the folder

5. After making sure that the My Files folder displays in the Save In combo box, click the Save button 

	Opening a File

	


The files you use could be created by you or someone else. They could be residing on your computer, on a floppy disk (or other media), or on a network. Once one of them is accessible, you can open it in your application.

You can open a document either by double-clicking its icon in Windows Explorer, in My Computer, from the Find Files Or Folders window, in My Network Places, or by locating it in the Open dialog box. To access the open dialog box, on the main menu, click File -> Open... You can also click the Open button on the Standard toolbar.

A shortcut to call the Open dialog box is Ctrl + O.

	[image: image26]Practical Learning: Using the Open Dialog

	


1. On the main menu, click File -> Open...

2. In the Open dialog box, click the arrow of the Look In combo box, select (C:); the (C:) represents your hard drive

3. Locate the folder that contains your exercises and display it in the Look In combo box

4. Click Allentown Car Sales1

5. Click the Open button

	Files Properties

	


Every file has some characteristics, attributes, and features that make it unique; these are its properties. You can access a file's properties from three main areas on the computer: 

· If the file is saved on the desktop and/or it has a shortcut on the desktop, if you open My Computer, Windows Explorer, or the folder (as a window) where the file is stored, right-click the file and click Properties. If the file were saved on the desktop, you would see only some of its properties, the most you can do there is to assign a Read-Only attribute. In My Computer and Windows Explorer, you will be able to change the file's properties.
Before opening a file or while in the Open dialog box, you can view some of the file's properties although you won't be able to change them.

· When the file is opened in Microsoft Excel, on the main menu, you can click File -> Properties to access its properties.

A file's properties are used for various reasons. For example, you can find out how much size the file is using, where it is located (the hosting drive and/or folder), who created the file, or who was the last person to access or modify it. The Properties dialog box is also a good place to leave messages to other users of the same file, about anything, whether you work as a team or you simply want to make yourself and other people aware of a particular issue regarding the file. 

	[image: image27]Practical Learning: Changing a File’s Properties

	


1. You should still have the Allentown Car Sales1 document opened. Otherwise open it.
On the main menu, click File -> Properties (in Microsoft Excel 2000, if you don't see the Properties menu, double-click the File menu; you can also press Alt, f, i).

2. Click the General tab. Notice the icon associated/registered with the file. Review the created, modified and accessed dates.

3. Click the Summary property sheet.

4. Click the Title text box and type Allentown Car Sales
5. Click the Subject text box and type Weekly car sales summary
6. Click the Manager text box and type Georgia Delaine
7. Click the Category text box and type Employees Sales Results
8. Click the Keywords text box and type accounting, sales, review, employees, cars
9. Click the Comments text box and type This is an attempted summary sales review, if you have any concern, please contact Mrs. Georgia Delaine, the Sales Accounts Manager. If you make any changes, send her an e-mail immediately
 
[image: image28]
10. Click the Statistics, Contents, and Custom tabs to review their content.

11. Click OK to register the changes and close the dialog box.

12. To close Microsoft Excel, on the main menu, click File -> Exit.

	


	Lists and Worksheets

	


  

	The Categories or Columns of a List

	


  

	Introduction to Lists

	


	Imagine you have a list of movie directors and you want to group their names into a list. Here is an example:

Rob Reiner, Jonathan Lynn, Bruce Beresford, Jonathan Demme, Adrian Lyne

This is a one-dimensional list. While working on this list, you may decide to create a video collection and make the above items into a formal list. A typical movie provides such information as its length, its rating, the year it was released, etc. To create such a list, you would group items by categories. One category may contain the titles of the videos. Another category may contain the names of the directors, and so on.

To better organize a list, you may create each category, then enter the value of each category that corresponds to a particular video. Here is an example:

Video Title
Director
© Year
Length
Format
Rating
A Few Good Men

Rob Reiner

1992

138 Minutes

VHS

R

The Distinguished Gentleman

Jonathan Lynn

 

112 Minutes

DVD

R

The Lady Killers

Joel Coen & Ethan Coen

 

104 Minutes

DVD

R

Fatal Attraction

Adrian Lyne

1987

120 Minutes

VHS

R

Her Alibi

Bruce Beresford

1989

94 Minutes

DVD

PG-13

The Manchurian Candidate

Jonathan Demme

2004

129 Minutes

DVD

R

This type of list is called a table: A table is a two-dimensional list that contains one or different categories of items and each category is represented with a particular value. A category of values is also called a column. Under each category, you may have a group of values that belong to the same entry. Such a group of values is called a row or a record. In the above table, the values "A Few Good Men", "Rob Reiner", "1992", "138 Minutes", "VHS", and "R" constitute one row one record.

[image: image30]Practical Learning: Introducing Lists

· Open the Cherry Pumpkin Day Care1 file

Introduction to Columns

To make it easy to create a type of list like the above, Microsoft Excel provides a ready-made arrangement of columns and rows. To easily identify each category of the list, a column is created and displays one or two letters or characters. The most left category has a label of A. The second has a label of B, and so on. The area that displays the label of a column can be referred to as the column header.

There are 255 of these columns in a document and the last one is labeled IV

[image: image31]
When you start a document, also called a workbook, in Microsoft Excel, the application makes all these columns available. You can use all of them or just a few, but they are always available.

[image: image32]Practical Learning: Checking Columns

1. To see the number of columns, click and hold the mouse on the right arrow button of the horizontal scroll bar: [image: image33]
2. Release the mouse and press Ctrl + Home

Columns Selections

At times you will almost want to alter the display of a column or various columns. You have to select that column or the group of columns first. Another reason you may need to select a column or a group of columns is because you would need to take some action on it. Some of these issues will be addressed soon, some others will be reviewed as we move on.

You can select a column or a group of columns using the mouse, the keyboard, or a combination of both. To select a column, you can click (with the left mouse button) a column header; it would get selected and all small boxes under it. To select a column using the keyboard, click anything under it, then press and hold Ctrl. While Ctrl is down, press the Space bar and release Ctrl.

You can also select more than one column. Selecting columns in a range consists of selecting adjacent columns. To perform this type of selection, you can use either the mouse or a combination of the mouse and the keyboard. To select columns in a range, click one column header and hold the mouse down. Then drag in the direction of the range. Alternatively, to select a range of columns, click one column at one end of the desired range. Press and hold Shift. Then click the column at the other end, and release the mouse.

Random selection consists of selecting columns that are not adjacent. For example, this allows you to select columns B, D, and H. To do this, click one column header, press and hold Ctrl. Then click each desired column header. When you have selected the desired columns, then release the mouse. 

[image: image34]Practical Learning: Selecting Columns

1. To select a column, click the column header D

2. To select more than one column, click column header C and hold the mouse down. While the mouse is still down, move it right until column F is selected, then release the mouse
  

[image: image35]
3. To select columns in a range, click column header B

4. Press and hold Shift, then click column header E

5. Release Shift

6. To select columns at random, click column header H

7. Press and hold Ctrl

8. Click column headers B, E, and C

9. Release Ctrl

10. Click any box under column header D

11. To select a column with the keyboard, for example column D, press Ctrl + Space

 

The Width of a Column

To display the information under it, a column uses a set width. The width of a column is the distance from its left border to its right border. By default, when Microsoft Excel comes up, all columns use the same width. You are allowed to change the width of one column or a group of columns.

To change a column's width, you can right-click it, select Column Width... from the shortcut menu, type the desired width and press Enter. If you want to make sure that all data in the column always displays, you can ask Microsoft Excel to resize the whole column according to the widest entry in the column. To achieve that, you would click any box under that column, then double-click the short line that separates the column header from the column on its right (if you are on the most right column, that will be the line that serves as the column's right border). The other alternative you have is to click and hold the short line that separates a column to its right neighbor, drag left or right until the small yellow box displays the width value you desire, then release the mouse.

You can also resize a group of columns. First, select the columns you want to work on and proceed as if they were one column.

[image: image36]Practical Learning: Controlling Columns Width and Rows Height

1. Open the DAWN Report2 workbook and, if necessary, click Sheet1

2. Position the mouse between columns A and B until the mouse turns into a short line with double horizontal arrows [image: image37]
3. Then double-click. That resizes column A to the box that has the widest entry, in this case Rank

4. Position the mouse on the separator of column headers C and D, then click and drag in the right direction until the small yellow box displays Width: 10.00
  

[image: image38]
5. Release the mouse

6. Double-click the separator line between columns D and E

7. Double-click the separator of columns H and I and of columns I and J

8. Right-click column E, click Column Width..., type 4 and press Enter. Notice that the column has been resized for a 4” width

9. Press Ctrl + Home

10. To save the workbook, press Ctrl + S

Hide and Unhide Columns

When working on a list, you don’t always need all columns displaying all the time. You can hide a column whose presence is not required at a particular time. In Microsoft Excel, you can hide one or more columns.

To hide a column, while the column or a box under that column is selected, on the main menu, click Format -> Column -> Hide. The column will disappear from the screen but it is not deleted. To unhide the column, on the main menu, click Format -> Column -> Unhide.

The Records or Rows of a List

  

Introduction to Rows

As mentioned for the list of videos above, when creating a list, you typically enter a necessary piece of information under each column until you reach the right end of the list. The values that share the same line are called rows. To make it easy with the creation of a list, Microsoft Excel provides ready made rows and each is identified with a number. The most top row is numbered 1. The row under it is named 2, and so on. The gray area that displays the number of the row can be referred to as the row header.

Microsoft Excel provides 65536 rows:

[image: image39]
You can use just a few of them for your assignment but all of them are always available.

Rows Selections

As done with columns, you can select one row or a group of rows. You can also select rows at random. You can perform selections using the mouse, the keyboard, or a combination of both.

To select a row, you can just click its row header. To select a row using the keyboard, click any box on its right, press and hold Shift. While Shift is still down, press the Space bar and release Shift.

To select a range of rows, you can click one row header and hold the mouse down. Then drag in the direction of the range. Alternatively, to select a range of rows, click one row at one end of the desired range. Press and hold Shift. Then click the row at the other end, and release the mouse.

To select rows at random, click one row header, press and hold Ctrl. Then click each desired row header. When you have selected the desired row, then release the mouse. 

[image: image40]Practical Learning: Selecting Rows

1. To select a row, click the row header 4

2. To select more than one row, click row 2 and hold the mouse down. While the mouse is still down, move it down until row 8 is selected

3. Release the mouse

4. Click any box on the right side of row 5

5. To select a row, for example row 5, press Shift + Space

6. To deselect, press the right arrow key

A Row's Height

To display the contents of boxes on its right, a row uses a set height. The height is the distance from the top to the lower borders of the row.

To change the height of a row, you can position your mouse on its lower border, click and drag down until you get the desired height. Then release the mouse. You can also right-click a row header and click Row Height. This calls the Row Height dialog box that allows you to enter the numeric value of the desired height and press Enter.

After selecting various rows, you can also change the heights of a group of rows. 

[image: image41]Practical Learning: Controlling Rows Height

1. The DAWN Report2 workbook should still be opened.
Press Ctrl + Home

2. Right-click row 2 and click Row Height...

3. Type 24
  

[image: image42]
4. Press Enter and press Ctrl + Home

5. Position the mouse on the separator of rows 3 and 4 until the mouse turns into a narrow line with vertical arrows [image: image43]
6. Then click and drag down slowly. A small yellow box allows you to evaluate the height
  

[image: image44]
7. When you get to Height: 24, release the mouse

8. Select rows 6 and 7

9. Right-click row 6 and click Row Height...

10. Type 17.25 and click OK

11. Press Ctrl + Home

12. To save the workbook, press Ctrl + S

Hide and Unhide Rows

As mentioned earlier, Microsoft Excel makes all of the rows of a sheet available while you are working. If at a certain time you don't need to display a certain row, you can hide it. In the same way, you can hide more than one rows.

To hide a row, while that row or a box on its right is selected, on the main menu, click Format -> Row -> Hide. The row will disappear from the screen without being deleted. To unhide the row, on the main menu, click Format -> Row -> Unhide.

Excelling With Cells

  

Introduction to Cells

The white boxes under the column headers and on the right side of the row headers are called cells. The cells are probably the most important objects of a list because they display the actual values of the list.

In Microsoft Excel, you cannot change the label on either a column header or a row header. Because of this, if you want to create your own column headers with labels you can easily identify, you must use one or more of the cells under the column headers. In the same way, you cannot change the numbers used to identify the rows. Instead, you can use the cells on the right side of the row headers to enter new values. This means that the primary job of cells is to receive or display values that make up a list.

A cell is the intersection of a column and a row. When Microsoft Excel starts a workbook, it creates 255 * 65536 = 16,711,680 cells. You can use just a few of them, as will usually be the case, or you can use as many as you want but they are always available.
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	Location of a cell

	


	Whatever you are doing on a cell, it is always important to know what cell you are working on. The minimum piece of information you need about a cell is to know which one you are using at a particular time. To make this recognition a little easier, each cell has an address also called a location. This address or location also serves as the cell's primary name.

To know the location of a cell, you refer to its column and its row. The combination of the column and the row's labels provides the address or name of a cell. When you click a cell, its column header receives a border thicker than the other column headers. In the same way, the row header of a selected cell is thicker than the other row headers. To know the name of a cell, you can refer to the Name Box, which is located at the intersection of columns and rows' headers:


	[image: image54]


	Cells Selection 

	


	Before doing anything on a cell or a group of cells, you must first select it. Selecting cells is almost equivalent to highlighting a word in a text document. And like a text document, various techniques are available here.

The Active Cell
At almost any time, at least one particular cell on the worksheet is selected. A selected cell has a thick border that sets it apart from the other cells. This is important because you always need to know where the changes you are making are being applied. This means that, whatever you type or format will apply to that particular cell. Sometimes you will want to work on many cells simultaneously. Therefore, you first have to select the intended cells before proceeding.

Other Cells Selections
At times you will almost want to alter the looks of a column, a row, various columns, or various rows. Once again, you have to select them first. Another issue involved with selecting cells, rows, columns, or rows allows you to clear, freeze, or hide some of these components. Some of these issues will be addressed soon, some others will be reviewed as we move on.

To select one cell, just click it. To select another cell, click the new one.

To select cells under the same column, click and hold your mouse on one cell, then drag down (or up) to the last cell.

To select cells on the same row, click one of the cells, then drag right (or left) to the last cell. 

To select cells at random, click one of the cells involved in the selection (any of the cells), press and hold Ctrl, then click each one of the desired cells. When the cells have been selected, release Ctrl. 

To select cells on the same row using a combination of the mouse and keyboard, give focus to a cell on one end, press and hold Shift, then click the cell that will be at the other end. Release Shift.

To select more than one cell, press and hold Shift. If you press the right arrow key, the currently highlighted cell and the cell to its right would be selected. If you press the down arrow key, the current cell and the cell under it will be highlighted. You can also press the left or up arrow key. You can press the arrow key many times in the direction of your choice. Once you have achieved the selection you want, release the Shift key.

To select all cells on a worksheet, you can press Ctrl + A. Alternatively, you can click the button at the intersection of the column header and row headers.


	[image: image55]Practical Learning: Selecting Cells

	


	1. To access the Cherry Pumpkin Day Care1 file, on the main menu, click Window and click it

2. To select one cell at a time, click cell B6

3. Click cell C4

4. Click cell E10

5. To select multiple cells on the same row, position the mouse on cell B5, your mouse turns into a big + sign [image: image56]
6. Click and hold down the mouse

7. Drag the mouse in the right direction until Laurie in cell E5 is selected, then release the mouse. Notice that four cells are selected

8. Position the mouse on cell D4, then click and hold the mouse down. Drag the mouse down until Hamilton in cell D9 is highlighted

9. Release the mouse. Notice that the range of cells on the same column is selected.

10. Click cell B4 and hold the mouse down

11. Drag the mouse right and down to cell D10 (Bassano) until that cell D10 is included in the highlighted range

12. Release the mouse. That selects adjacent cells in the same area.

13. To select all cells, click the button on the intersection of the column and row headers

14. To deselect, click cell C5

15. To select one cell at a time, press the down arrow key; that selects cell C6

16. Press the right arrow key; that selects cell D6

17. Press the up arrow key

18. Press the left arrow key

19. To select multiple cells on the same column, press and hold Shift (with your left hand)

20. While Shift is down, press the down arrow key twice, and then release Shift. That selects multiple cells on the same column.

21. Press the up arrow key

22. To select multiple cells on the same row, press and hold Shift

23. Press the right arrow key three times, and release Shift.

24. Press the left arrow key

25. Click cell C5

26. Press and hold Shift

27. To select adjacent cells, while Shift is still down, press the left arrow key one time and the down arrow key four times, then release Shift

28. To deselect, press the left arrow key

29. Click cell B6

30. To select adjacent cells, press and hold Shift, click cell D10, then release Shift. All cells in the range are included in the selection

31. To select cells at random, click cell D5. Press and hold Ctrl. While you are holding Ctrl, click cells B7, H10, and E11

32. Release Ctrl

33. Press Ctrl + Home

34. To select the whole worksheet, press Ctrl + Shift + Space

35. To deselect, press the right arrow key

36. To select the whole worksheet again, press Ctrl + A

37. To deselect, press the down arrow key


	The Width of a Cell 

	


	A cell in a Microsoft Excel worksheet doesn't have dimensions of its own. It uses those imposed to it. Since at least one cell in the worksheet always has focus, to change the column width under which that cell is selected, on the main menu, you can click Format -> Columns. You have a lot of options: 

· If you click Width..., you will be able to type the new width value and click OK

· If you click AutoFit Selection, the column will be resized to the width of the selected cell (the active cell that has focus)

· If you are not sure or you just want to restore the default column width, click Standard Width... accept 8.43, then press Enter.


	[image: image57]Practical Learning: Setting Column Width Using Cells

	


	1. To access the DAWN Report2 file, on the main menu, click Window and click it. If necessary, click Sheet1

2. Click cell B7

3. On the main menu, click Format -> Column -> AutoFit Selection

4. Click column F to select the whole column

5. On the main menu, Format -> Column -> AutoFit Selection. Notice that the whole column has been resized to the widest entry

6. Click cell G8

7. On the main menu, click Format -> Column -> AutoFit Selection. Now the column has is resized to the width of cell G8


	Cells Names

	


	We saw that a cell, each cell, has a name, which is also its location, which is provided by a combination of its parent column and its parent row. Instead of using the column and row to identify a cell, Microsoft Excel allows you to change the name of a cell to your liking. In fact, you can combine cells and name the group to anything you like.

To change the name of a cell, first click it. Then, in the Name Box, replace the name with the desired name and press Enter. Alternatively, to create a new name for a cell, first select it. Then, on the main menu, click Insert -> Name -> Define... In the Names In Workbook text box of the Define Name dialog box, type the desired name and click OK.

To change the name of a group of cells, first select them, using the techniques we learned for selecting cells. Then, in the Name Box, replace the string with the new name. In the same way, to create a name for a group of cells, after selecting them, on the main menu, click Insert -> Name -> Define... In the Names In Workbook text box of the Define Name dialog box, type the desired name and click OK.
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	1. Open the DAWN Report1 file

2. To name a cell, click cell C2

3. Click in the Name Box. That highlights C2. Type MainTitle and press Enter
 
[image: image59]C

4. Select cells A7:D16

5. Click in the Name Box to select the current name. Type EREpisodes and press Enter

6. Select cells F7:I16

7. On the main menu, click Insert -> Name -> Define...

8. In the Define Name dialog box, replace the contents of the Names In Workbook combo box with RelatedDeaths
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9. Click OK

10. To review names, select cells A7:D16
 
[image: image61]
11. Save and close the file


  

	Lessons Conventions

	


	[image: image62]From now on, unless specified otherwise, the following conventions will be used 


	Instruction
	Means

	Click G5
	Click cell G5

	Select B2:F8
	Select cells from B2 to F8, and that will include all cells in the range B2 to F8

	Select cells D4, B10, A2, and H16
	Select only those cells at random

	Click cell F4
	Using your mouse, click cell F4. On the other hand, if I write press F4, I mean using your keyboard, press function key F4. Remember that "click" refers to using the mouse and "press" refers to using the keyboard

	Select row 4
	Position the mouse on the row header which is the gray box where the row number is displaying, then click

	Select rows 4 and 5
	Use one of the methods we learned to select the row headers

	Select rows 4:8
	Use one of the methods we learned to select the row headers

	Select column E
	Position the mouse on the column header which is the gray box where the column letter(s) is displaying, then click

	Select columns D and F
	Use one of the methods we learned to select the column headers

	Select columns C:H
	Use one of the methods we learned to select the column headers


  

	Worksheets

	


  

	Introduction

	


	The group of cells that constitute a document is referred to as sheet and those cells are spread all over it. For this reason, a document whose main purpose is to present a list as a group of cells is referred to as spreadsheet.

As you may realize, Microsoft Excel's primary purpose is to help you create lists using readily available cells spread on a sheet that resembles a piece of paper. For this reason, Microsoft Excel is referred to as a spreadsheet application. A list created on sheet is called, in Microsoft Excel, a worksheet. When Microsoft Excel opens, it starts with three worksheets. If you don't need all of them, you can delete those that appear useless. You can also add new worksheets as you see fit. If you want Microsoft Excel to always start with less or more worksheets, you can change its default settings in the Options dialog box accessible from the Tools menu. Even when they belong to the same document, worksheets can be treated as independent entities, although it is more suitable that they be treated as a unit.


	Selecting a Worksheet

	


	In some circumstances, you will need to perform a general action on a worksheet. Before doing this, you may need to select the contents of the whole worksheet first.

Since there are usually many worksheets presented to you, each is represented by a tab on the lower left corner. Therefore, to select a worksheet, you can click its tab. To select a worksheet using the mouse, you can press and hold Ctrl. Then press either Page Up or Page Down. Once the desired worksheet has been selected, you can release Ctrl.

If you have many worksheets, to select a range of worksheets, click a tab that is considered one end of the range. Press and hold Shift, then click the tab at the end of the range and release Shift.

To select worksheets at random, click one of the desired worksheets. Press and hold Ctrl. Then click each desired worksheet. When the selection has been made, release Ctrl.
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	1. Open the Grier Summer Camp3 workbook

2. To select a worksheet, in the lower left corner, click Sheet3

3. To select another worksheet, click Sheet2

4. Press and hold Ctrl

5. Press Page Up. Notice that you are switched to Sheet1

6. Press Page Down

7. While you are still holding Ctrl, press Page Up. Notice that you are now in Sheet1

8. Release Ctrl

9. Click Sheet1 if necessary.
To select more than one worksheet, press and hold Ctrl and Shift

10. Press Page Down once. Notice that Sheet1 and Sheet2 have been selected.

11. Press Page Down again to select three worksheets

12. Release Ctrl and Shift then click Sheet1


  

	Worksheets Names 

	


	The starting worksheets are named Sheet1, Sheet2, and Sheet3. You can change any or all of these worksheet names.

To rename a worksheet: 

· You can double-click its sheet tab, then type a new name

· You can right-click a sheet’s tab, click Rename, and type the new name

· While a certain worksheet is selected, on the main menu, you can click Format -> Sheet -> Rename, and type the new name


	[image: image64]Practical Learning: Naming Worksheets

	


	1. To rename the first worksheet, double-click the Sheet1 tab to put it in edit mode

2. Type Request For Time Off
3. To rename the second worksheet, right-click the Sheet2 tab and click Rename from the shortcut menu

4. Type Tuition Reimbursement
5. To rename the third worksheet, click Sheet3 to make it the active worksheet

6. On the main menu, click Format -> Sheet -> Rename

7. Type Time Sheet and press Enter
 
[image: image65]
8. Save the workbook

  


	Worksheets Sequence 

	


	By default, worksheets are positioned in a numbered format that makes it easy to count them. More often you will find that, after creating a few of them, you are not satisfied with their positions. You should be able to reposition them in a manner that suits your particular scenario.

To move a worksheet, click and hold the mouse on its tab, then move the mouse in the direction of your choice. While you are moving the worksheet, the mouse pointer will turn into a white piece of paper and a small down-pointing triangle will guide you. Once the small triangle is positioned in the desired location, release the mouse.
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	1. Click and hold the mouse on the Request For Time Off tab

2. Move the mouse in the right direction. Notice that the mouse pointer turns into a white piece of paper and there is a small triangle that guides you

3. Once the small triangle is positioned between Tuition Reimbursement and Time Sheet, release the mouse
 
[image: image67]
4. Now we will move the Time Sheet worksheet because that is the form that employees are using on a regular basis before anything else.
Click the hold the mouse on the Time Sheet tab

5. Move the mouse in the left direction

6. When the small triangle is positioned to the left of Tuition Reimbursement, release the mouse

7. Save the workbook


	Adding New Worksheets

	


	As mentioned already, when Microsoft Excel comes up, it displays three worksheets. We also mentioned that you can change this default number in the Options dialog box. You can add a new worksheet anytime if you judge it necessary.

Some workbooks are quite complete with just one worksheet, but others need as many worksheets as possible. The number of worksheets you use in a particular workbook is conditioned by your needs and the memory of your computer.

The easiest way to insert a worksheet in your workbook is by clicking Insert on the main menu, and then clicking Worksheet. This would add a new sheet on the left side of the active worksheet. You can also add a blank or formatted worksheet. Right-click the sheet that will precede the new worksheet and click Insert… From the Insert dialog box, you can choose to insert a blank worksheet or insert one of the existing templates as a worksheet.
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	1. To start a new workbook, press Ctrl + N

2. On the main menu, click Format -> Sheet -> Rename

3. Type Students Info
4. Double-click the Sheet2 tab to highlight it

5. Type Emergency Information
6. Right-click the Sheet3 tab and click Rename

7. Type 6th Grade and press Enter

8. Right-click the 6th Grade tab and click Insert…

9. In the Insert dialog, make sure that the General property page is selected; if it is not, click it. Click Worksheet and click OK

10. Right-click the new Sheet4 tab and click Rename

11. Type 5th Grade and press Enter

12. Here is another technique to add a worksheet. On the main menu, click Insert -> Worksheet. That will insert a new worksheet

13. To change the name of the current worksheet, on the main menu, click Format -> Sheet -> Rename

14. Type 4th Grade and press Enter

15. One more technique to add a worksheet is by using a shortcut. Press Shift + F11. That’s the shortcut to insert a new worksheet.

16. Double-click the new Sheet tab to highlight it

17. Type 3rd Grade and press Enter

18. On the main menu, click Insert Worksheet. That inserts another worksheet.

19. On the main menu, click Format -> Sheet -> Rename

20. Type 2nd Grade and press Enter

21. Press Shift + F11 to insert another worksheet

22. On the main menu, click Format -> Sheet -> Rename

23. Type 1st Grade and press Enter

24. Save the workbook as Red Oak High School3 in your Exercises folder


	Removing Worksheets

	


	As your work progresses, you will decide how many worksheets you need for your particular workbook. Just as we learned to add worksheets, you can delete or remove the worksheets you don't need anymore. Since a worksheet is not a file, when you delete a worksheet, it is permanently gone; that is why you will get a confirmation message. 

To delete a workbook, you can right-click its tab and click Delete.


	[image: image69]Practical Learning: Deleting Worksheets

	


	1. To delete a worksheet, right-click the Emergency Information tab and click Delete
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2. After reading the message box, click OK...

3. Move and arrange the worksheet so that from left to right you will have Student Info, 6th Grade, 5th Grade, 4th Grade, 3rd Grade, 2nd Grade, and 1st Grade

4. Save the workbook


	Hide and Unhide Worksheets

	


	As mentioned already, by default, Microsoft makes three worksheets available to you. We also reviewed how you can add new ones or delete some of them. Instead of deleting a worksheet, you can hide it for any reason you judge necessary. If the workbook contains more than one worksheet, you can hide one or more worksheets or even the entire workbook.

To hide a worksheet in a workbook, click any cell in that worksheet to make it active. On the main menu, click Format -> Sheet -> Hide. The worksheet’s tab will disappear from the screen although it is not deleted. To hide a group of worksheets, selecte the desired worksheets. Then, on the main menu, click Format -> Sheet -> Hide. To unhide the hidden worksheets, on the main menu, click Format -> Sheet -> Unhide. You are presented with a list of the hidden worksheets. If you have more than one hidden sheet, select the desired worksheet and click OK.
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	1. To access the Grier Summer Camp1 workbook, on the main menu, click Window and click it. If necessary, display the Registration worksheet

2. Click column F to select the whole column

3. On the main menu, click Format -> Column -> Hide. Notice that the list doesn't currently display the DOB

4. To unhide the columns, select columns E:G

5. On the main menu, click Format -> Column -> Unhide

6. Close the workbook without saving it


  

	Worksheets and the Web

	


	As the Internet has become significantly important and unavoidable, you can publish your data and make it available to almost any computer in the world.

An intranet is a privately owned, company centered, group of computers connected inside of a particular company using the same technology as the Internet to share and exchange information. This allows you to publish your information inside of the company even if different employees use different computers and operating systems.

In Microsoft Excel, you can publish just one worksheet or the whole workbook. To perform publishing, first decide on what you want to publish, a worksheet or the whole workbook.

We will save the current workbook as a web page.
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	1. Open the Red Oak High School4 workbook

2. On the main menu, click File -> Web Page Preview

3. Notice that the whole workbook (with its worksheets) gets previewed in the browser
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4. To save the Students Grades worksheet, on the main menu, click File -> Save As Web Page...

5. On the Save As dialog box, click the Selection: Sheet radio button

6. Change the string in the File Name with students_grades
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7. Click Save

8. Open the Red Oak High School5 workbook and click the Students Grades Summary worksheet

9. On the main menu, click File -> Save As Web Page…

10. Type the File Name as roshgradesummary
11. Click the Selection: Sheet radio button

12. Click the Change Title button.
Type Red Oak High School Grades Summary
13. Click OK

14. Click Publish

15. In the Publish As Web dialog, make sure that the Choose combo box displays Items On Students Grade Summary. Also make sure the Add Interactivity With check box is cleared.

16. Check the Open Published Web Page In Browser check box.

17. Click Publish

18. After viewing the published web page, you can close it.


  

	The Workbook

	


	Microsoft Excel doesn't just stop at mere lists. Once a list has been created, the application allows you to perform various types of operations related to a list. It also can be used to process business and financial calculations of various kinds. To make it even more powerful, you can create more than one list; that is, you can use more than one sheet. The group of worksheet that constitute the lists of a document is called a workbook.
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	1. On the main menu of Microsoft Excel, click File -> Save As Web Pages…

2. In the File Name box, type roshstudentsgrades
3. Make sure that the Entire Workbook radio button is selected

4. Click Save

5. Minimize all opened applications

6. On the Desktop, double-click My Documents (if you are using Microsoft Windows NT, locate the folder where your workbook was saved). Double-click Microsoft Excel Exercises. Double-click the roshstudentsgrades web page

7. After viewing the result, you can close the browser

8. Exit from Microsoft Excel


	


	Printing

	


  

	Standard Printing

	


  

	Introduction

	


	Printing allows you to get your work on paper. This is useful both for referencing and sharing your work. Data available on your worksheets can be explored and exploited in various areas including visual presentation or book review. Since printing involves different issues, it is important to know what Microsoft Excel offers.

There are two main ways you can get data from your worksheet to the printer: by clicking the Print button [image: image77]on the Standard toolbar or by performing custom configuration from the main menu.

Before printing, make sure that a printer is available for your computer. This means that, a printer could be attached to your computer or you may use a networked shared printer. Sometimes, more than one printer will be available to you.

To check whether a printer is available for your computer, on the Taskbar of:

· Windows 9X and 2000, you can click Start -> Settings -> Printers

· Windows XP, you can click Start -> Controls Panel, click Printer and Other Hardware, then click View Installed Printer or Fax Printers

· Windows Server 2003, on the taskbar, you can click Start -> Control Panel -> Printers and Faxes. You would see a list of the printers available to you.

[image: image78]
This action would open the Printers window. If more than one printer are available, they will appear on the list. The printer with the check mark icon is your default printer; this means that whenever you send a job to the printer, if you don’t change anything in the printing process, the default printer will do the job.

If no printer is attached to your computer but you still need to at least print preview your worksheet, you can install a “fake” printer on your machine. To do that, from the Printers window, double-click Add Printer and follow the instructions of the Add Printer Wizard.

The easiest way to print a worksheet is by clicking the Print button [image: image79]on the Standard toolbar. To have more control over the printing process, you will use the options available from the main menu. 

The Standard Toolbar’s Print Button

The Print button [image: image80]on the Standard toolbar offers the quickest way to print data. Once you click it, it sends your document directly to the printer. The Print button doesn’t provide any configuration, therefore, you should use it only when the job to be printed is not large or particularly complicated.

In Microsoft Excel 2000 and later versions, if the Print button is not displaying on the Standard toolbar, click the More Buttons button on the toolbar and click the Print button. 

[image: image81]Practical Learning: Using the Print Button

1. Start Microsoft Excel and open the Grier Summer Camp1 workbook
  

[image: image82]
2. Click the Registration tab if necessary to activate it
On the Standard toolbar, click the Print button [image: image83]
(If the Print button is not displaying, click the More Buttons button.)
Notice that the document is printed vertically, on two sheets of paper

3. Click the T-Shirts to Order tab to activate it

4. On the Standard toolbar, click the Print button [image: image84]
Notice the result on the printed document

Print Preview

Print preview allows you to open a special window that would present the document as it would appear when it is printed. In Microsoft Excel, the Print Preview window is not just used to preview the printed document. There are other configurations you can perform. The Print Preview window can be accessed from the Standard toolbar, the File menu, or the Print dialog box.

The Print Preview window features a toolbar that allows you to perform various operations, some of which are closely related to printing. Some of these actions are related to issues we will review in this and the next lesson. 
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	Button
	Role

	[image: image94]
	Allows you to preview the next page of a document that spreads more than one page. We will review it in the section on Page Breaks

	[image: image95]
	The Previous button would take you to the previous section of the printed page. We will review it in the section on Page Breaks

	[image: image96]
	Since the Print Preview window is not used to read the document but to preview it, if you want to take a closer look at the document, click the Zoom button to zoom in. If you click the zoom button again, the preview area would come back to the previous display.

	[image: image97]
	Used to call the Print dialog box. We will review it in the section on the Print dialog box.

	[image: image98]
	Would call the Page Setup dialog. The Page Setup dialog box will be reviewed in another section

	[image: image99]
	Besides displaying a preview of the printed paper, the Print Preview window allows you to "enlarge" or "squeeze" the document. To do this, you can first click the Margins button. Once clicked the window would display lines around the document: 

[image: image100]
Based on this, to shrink, enlarge, heighten or narrow the printed document, you can click one of the lines and drag in the desired direction.

	[image: image101]
	Allows to set or control page break(s)
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	Used to close the Print Preview window
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	Provides help on various issues related to this window


	[image: image104]Practical Learning: Using the Print Preview Window

	


	1. The Grier Summer Camp1 workbook should still be opened. Click the Registration tab sheet

2. On the Standard toolbar, click the Print Preview button [image: image105].

3. Click the Print button to call the Print dialog

4. On the Print dialog, click Cancel

5. On the main menu of Microsoft Excel, click File -> Print Preview

6. On the toolbar of the Print Preview window, click the Margins button. Notice the margin lines on the paper.

7. Position your mouse on the left line. Notice that your mouse pointer changes to a cross with horizontal arrows

8. Drag your mouse to the right. While you are dragging, observe the dimension on the left side of the Status bar

9. Keep dragging until the dimension on the Status Bar displays something between 1.48 and 1.52 (you should have the option between 1.49 and 1.51; if that is the case, stop at 1.51)

10. Click the Margins button again to dismiss the margin lines

11. Click the Next button to view the second page

12. Click the Close button on the Print Preview window


	Print Configuration

	


  

	The Print Dialog Box

	


	The printing process in Microsoft Excel offers all the classic default features of any other application and other specific issues related to a spreadsheet. To control printing on your worksheet, you use the Print dialog box. The Print dialog box is accessible from the main menu by clicking File -> Print...

The Print dialog box displays some of the items you are already familiar with such as the title bar, the Context Sensitive Help, the close, the OK, and the Cancel buttons.
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	When a printer (at least one) is available for your computer, it is usually set as the default printer and it displays on the Printer Name combo box. If more than one printer is available, when you decide to print, click the Printer Name combo box and select the desired printer from the list.

If your worksheet is long, sometimes very long, and expand on various pages, you have the option of printing all the pages or range of pages. This can be configured in the Print Range section of the dialog box.

You can also select some sections of the worksheet and print just that. This is configured in the Print What section. By default, Microsoft Excel prints the active worksheet, that is, the worksheet that is displaying in the background. If you decide to print everything on your workbook, you can click the Entire Workbook radio button.

For a presentation or any other purpose, if you want to print various copies of the worksheet, increase the number by using the Number Of Copies spin button.

The Properties button allows you to configure or change some of the properties related to the selected printer.

One thing you should always do is to preview your worksheet before the actual printing, this allows you to have an idea of what your worksheet would look like on a piece of paper. You can preview your job by clicking the Preview button.


	[image: image107]Practical Learning: Using the Print Dialog

	


	1. Open the Cherry Pumpkin Day Care2 workbook and, if necessary, click the Registration tab to activate it

2. Select cells D5:G16

3. On the main menu, click File -> Print...

4. In the Print What section, click the Selection radio button

5. Using its spin button, increase the Number Of Copies to 2
  

[image: image108]
6. Click OK to print the selection in 2 copies.
Notice that each printed paper includes only the area previously selected.

7. Press Ctrl + Home to make sure the selection is deselected.


	Page Breaks

	


	When using the Print button on the Standard toolbar, the document printed on two pieces of paper. Whenever a document is longer than the default 11 inches height, the printing process will segment it in sections to fit the legal height. If you don’t like the way the printer sets the page limit, you can set your own and tell the printer where you want each page to start. To do that, you use the Page Break feature.

You don’t have to set a page limit the traditional way which consists of using the end of a real end of a page. Microsoft Excel allows you to start a new page anywhere on the worksheet. To set your own page end, first click the row that will start the subsequent page. Then on the main menu, you would click Insert -> Page Break. You should notice a line that points to the page break.  The document will be divided in at least 4 sections and each section represents its own page.

After you have worked with the page break, or if you don’t need the page break anymore, you can remove it. To remove a page break, on the main menu, you can click Insert -> Remove Page Break. 
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	1. Access the Grier Summer Camp1 workbook from the Window menu and click the Registration tab sheet to activate it

2. To set a page break, click row 28

3. On the main menu, click Insert -> Page Break

4. Click cell C10 to activate the 1st page

5. On the Standard toolbar, click the Print Preview button [image: image110]
Notice that the paper displays the upper section of the worksheet

6. Click the Next button to preview the other part of the document

7. Click the Close button on the toolbar

8. To remove the page break, click row 28 to activate it

9. On the main menu, click Insert -> Remove Page Break

10. To set various page limits, click row 22

11. On the main menu, click Insert -> Page Break

12. Scroll down and click row 40

13. On the main menu, click Insert -> Page Break.

14. Click cell B30. Notice that there are two lines of page breaks on the worksheet
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15. On the main menu, click File -> Print Preview
Notice that the preview displays a shorter area than previously

16. Click the Next button. Notice that, unlike previously, the Next and the Previous buttons are enabled: this is because the document is divided in three pages

17. Click Next again

18. To print the current worksheet, click Print

19. On the Print dialog, click OK

20. To remove the previous page breaks, click row 40

21. Press and hold Ctrl, then click row 28. That selects those two rows

22. On the main menu, click Insert -> Remove Page Break

23. To divide the worksheet in various page sections, click cell E28 to select it

24. On the main menu, click Insert -> Page Break
Notice that the document is divided in four sections

25. On the main menu, click File -> Print Preview

26. Click the Next and the Previous buttons a few times to preview all the sections

27. To print the current worksheet, click Print

28. On the Print dialog, click OK

29. To remove the page break, click cell E28

30. On the main menu, click Insert -> Remove Page Break


	Worksheet Area Printing

	


	Since a worksheet can grow very large and sometimes you don’t need all data available, Microsoft Excel allows you to select just one portion of the worksheet and send it to the printer.

In order to print an area of the worksheet, first select that area, then, on the main menu, click File -> Print Area -> Set Print Area. Even if you click somewhere else, the selected area still displays a distinguished border.

Once the desired area has been selected, you can proceed with printing.


	[image: image112]Practical Learning: Printing an Area

	


	1. Select cell C4:E20

2. On the main menu, click File -> Print Area -> Set Print Area

3. Press Ctrl + C. Notice the selection border on the range of cells

4. Press Ctrl + P to call the Print dialog

5. From the Print dialog, accept all defaults and click OK

6. To remove the border line on the range, on the main menu, click File -> Print Area -> Clear Print Area


	Page Setup

	


  

	Introduction

	


	The Page Setup dialog box allows you to specially configure and control many issues related to printing. To access it, on the main menu, you can click File -> Page Setup... The Page Setup dialog box is equipped with four property pages.


	The Page Property Page

	


  

	[image: image113]


	Whenever you ask Microsoft Excel to print the contents of a worksheet, by default, it prints the document vertically, this is considered as Portrait. Some and many of the worksheets spread wider than taller. Therefore, you should check or change their page orientation before printing. That is why you have the option of choosing one of the orientation radio buttons. If the document or the section to be printed is wider than taller, you can change the Orientation to Landscape.

By default, the printed document will adjust itself to 100% fitting a ratio of 1/1 page wide and tall. To change any of these settings, use the appropriate spin button in the Scaling section. The options are Adjust To, Fits To, and Page(s) Wide By.

By default, the paper size is set to the Letter paper dimension, which is 8.5 by 11 inches. If this doesn’t fit your desire, click the Paper Size combo box and select a different size from the list.

The result of the printed-paper depends on your printer. If your printer allows more configuration, click the Print Quality combo box and select a different setting.

The Print button would call the Print dialog that we saw earlier.

If you want to take a look at the printed result before actually printing, click the Print Preview button.

Although the Print button would call the Print dialog box, the Options button allows you to change or configure the properties of the printer.


	[image: image114]Practical Learning: Using the Page Property Sheet

	


	1. Open the DAWN Report1 workbook

2. On the main menu, click File -> Page Setup…

3. From the Page Setup dialog box, if necessary, click the Page tab to activate it
In the Orientation section, click the Landscape radio button

4. Click the Print button to call the Print dialog

5. In the Print dialog, click OK to print the spreadsheet


[image: image115]
	The Margins Property Page
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	The Margins property page allows you to control all four-margin sections of a printed-paper. By setting the proper width or height, you can control how much space will be left or untouched in the Top, the Left, the Right, or the Bottom sections of the printed paper.

You can create one or two special sections for the title or the lower areas of the printed paper; these are the Header and the Footer sections.

By default, a document prints starting on the top left corner of the paper. This may look awkward if your document contains just one section or a chart. Therefore the Margins property page allows you to center the content of the worksheet horizontally and/or vertically. This is done using the Horizontally or the Vertically check box in the Center On Page section.


	[image: image117]Practical Learning: Using the Margins Property Sheet

	


	1. Open the Grier Summer Camp1 workbook and click the T-Shirts to Order sheet
  

[image: image118]
2. On the main menu, click File -> Page Setup…

3. Click the Margins property page

4. In the Center On Page section, click both the Horizontally and the Vertically check boxes

5. Click the Print button

6. On the Print dialog box, click OK
Once the job has been printed, compare the current piece of paper with the one you printed previously
 


	The Header/Footer Property Page
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	The Header/Footer property page of the Page Setup dialog box allows you to set and configure some of the items you would like to display in the top and bottom sections of the printed document.

To configure one of the sections, you can click either the Custom Header or the Custom Footer buttons. The Custom Header button calls the Header dialog box. The Custom Footer button would call the Footer dialog box. Both dialogs look alike: 
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	Just remember that what you set in one will display in its corresponding section on paper. 

Since most of the buttons are not very explicit, whenever you want to find what a button is used for, you can right-click it and click What’s This. 


	Button 
	Name
	Role

	[image: image121]
	Font
	Used to change the font of what is displaying in the section

	[image: image122]
	Page Number
	Used to display an incremental number for each printed page.
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	Total Pages
	Displays the total number of pages of a document on the printed sheet.
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	Date
	Allows you to display the date the document is printed.
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	Time
	Will display the time the document is being printed.

	[image: image126]
	File Name
	 Can include the file name on the printed paper.

	[image: image127]
	Sheet Name
	Is used to display the name of the worksheet.


  

	[image: image128]Practical Learning: Configuring the Header/Footer Sections

	


	1. Access or open the DAWN Report1 workbook

2. On the main menu, click File -> Page Setup…

3. Click the Header/Footer property page

4. Click Custom Header...

5. Click the Left Section box to make it active
Type Center for Drug Studies
6. In the Left Section box, select Center for Drug Studies

7. Click the Font button [image: image129]
8. In the Font dialog box, change the Font to Times New Roman, the Font Style to Bold, and the Size to 11
9. Click OK

10. Click the Right Section box

11. Click the Date button [image: image130]
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12. Click OK

13. Click the Custom Footer button

14. Make sure the cursor is in the Left Section box
Type Gertrude McNeil and press Tab twice

15. Make sure your cursor is in the Right Section box
Click the Page Number button [image: image132]
16. Click OK

17. On the Page Setup dialog box, click the Page property page and, in the Orientation section, click the Landscape radio button

18. Click Print Preview

19. In the Print Preview window, click the Print button

20. On the Print dialog box, click OK


	The Sheet Property Page

	


	You have probably realized that some of the documents we would printing don’t include a worksheet’s header columns, header rows, or gridlines. This is because in most cases they can be ignored. In some circumstances, such as when performing some presentations or illustrations, you may want to print some or everything that is part of the worksheet. That’s what you can configure from the Sheet property page of the Page Setup dialog box:


	[image: image133]


	The Print Area text box allows you to delimit a section of your worksheet for printing. To use it, click its selection button [image: image134]. This would shrink the Page Setup dialog, allowing you to make a selection of the area you want to print. After setting the desired area, you can click the selection button [image: image135]to restore the Page Setup dialog box.

Most of the time, when creating a list of items, you would set the list headers only on top of the worksheet. As you continue entering the items, the list grows. If you decide to print such a long list that spreads on various pages, after the 1st page, the subsequent pages would not display their headers. This could be confusing in some circumstances. The Sheet property page allows you to set or select a row or range of rows that would display on top of every printed sheet. If you know the row or range of rows you want to use, you can just type it in the Rows To Repeat At Top text box, but the safest way to configure it is to click the selection button [image: image136], then click any cell in the desired row or click the desired cells. In either case, the whole row or the rows will be selected.

The Columns To Repeat At Left text box is used like the previous box except that, this time, it would display a particular column on the left side of each printed sheet.

If you want to print the gridlines, in the Print section, click the Gridlines check box.

If you want to display the column and row headers on your printed paper, click the Row And Column Headings check box.


	[image: image137]Practical Learning: What to Print From The Sheet

	


1. On the main menu, click Window -> Grier Summer Camp1 to open it. Click the Registration tab

2. On the main menu, click File -> Page Setup…

3. Click the Sheet property page

4. Click the selection button [image: image138]of the Print Area text box

5. On the worksheet, select cells C4:G28

6. Click the stop selection button [image: image139]
7. Click the Print button

8. From the Print dialog, click OK

9. On the main menu of Microsoft Excel, Window -> DAWN Report1

10. On the main menu, click File -> Page Setup…

11. Click the Page property page. Click the Landscape radio button

12. Click the Sheet property page to make it active

13. If there is anything in the Print Area text box, delete it
In the Print section, click the Gridlines check box

14. Also click the Row and Column Headings check box

15. Click the Print Preview button
 
[image: image140]
16. In the Print Preview window, click the Print... button

17. In the Print dialog box, click OK

18. On the main menu, click Window -> Grier Summer Camp1

19. On the main menu, click File -> Page Setup… and click the Sheet property page

20. In the Rows To Repeat At Top text box, click the selection button [image: image141]
21. Click cell B4 (Regist Date)

22. Click the stop selection button [image: image142]
23. Click the Print button.

24. In the Print dialog, click OK

25. Exit from Microsoft Excel. When closing the workbooks, anytime you are asked whether to save, click No
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	Data Entry

	


  

	Text Entry


	

	  

Introduction to Cells Text

As you are aware, when Microsoft Excel starts, it opens a workbook made of three worksheets. A worksheet is simply made of cells that are patiently waiting for you to enter data. You should first practice typing different kinds of items and see what happens.

At all times, at least one of the cells on the worksheet you are working on has focus. That cell is referred to as the active cell. That cell is surrounded with a thicker border. If you type something, it goes into the active cell. If you click a cell and start typing, the new entry will replace the content of that cell, whether that cell had data or not, this could be advantageous or disastrous.

To prevent a cell from being edited by the user, you can protect it and lock its content.

Data you type in a cell can consist of any kinds of characters, letters, numbers, etc. Sometimes, a long text will look like covering more than one cell; unless you merge cells, the text you type goes into one cell regardless of the length of the text.

A cell can contain as many as 64000 characters.
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Practical Learning: Editing Cells Contents

1. Start Microsoft Excel with a default workbook

2. Press Ctrl + Home. Observe the cell's name in the Name Box.

3. Press the down arrow key. Observe the cell's name in the Name box.

4. Press the right arrow key twice.

5. Press the up arrow key.

6. Press the left arrow key.

7. Click cell A2.

8. Click cell B4.

9. Click cell D12.

10. Click cell B4, type Honda
11. Press Enter. Notice that text is left aligned.

12. Type Buick and press Enter.

13. Type Mazda and press the down arrow key.

14. Type Folks Wagon
15. On the main menu, click Edit -> Undo typing. That deletes the content of cell B7.

16. Type VW press the down arrow key.

17. Type h and notice that the cell is auto-completed with Honda.

18. Click cell B2, type Make and press the right arrow key.

19. Type Model and press the right arrow key.

20. Type Month and press the right arrow key.

21. Type Miles and press the right arrow key.

22. Type rice and click the Enter button [image: image149.png]


.

23. Type Price and press the right arrow key.

24. Type Contact and press the right arrow key.

25. Type Published
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26. Click cell C4, type Corolla and observe the signs on the left of the Edit Formula button on the Formula Bar.

27. Click the Cancel button on the Formula Bar [image: image151.png]



28. Type Accord and press Tab

29. Type 1988
30. Notice that the number is left aligned. Press Tab, notice that the number is right aligned now.

31. Type 172460 and press right arrow key.

32. Type 2350 and press the right arrow key.

33. Type Brenda and press the right arrow key.

34. Type 08/05/2000 and press Enter. Notice that the entry is recognized as a date value.

35. Click cell D2 and type Year
36. Notice that when you click a cell and start typing, the new word replaces the old cell content.

37. Press the right arrow key.

38. Click cell B8. Double-click Honda in the Formula Bar to select it. Type Ford
39. Double-click cell E2. Notice that the cursor is positioned in the cell.

40. Press End, press Backspace to delete s, type age
Now the cell displays Mileage.

41. Click cell G5, type David and press the down arrow key.

42. Type b and press Enter. Notice that Microsoft Excel completed the cell with the word Brenda.

43. In cell G7, type Alex and press Enter .

44. To undo your last action, press Ctrl + Z. Now cell G7 is empty.

45. To redo the last action, press Ctrl + Y. That puts Alex back in cell G7.

46. To save the current workbook, click the Save button [image: image152.png]


on the Standard toolbar.

47. Set the name of the file to Allentown Car Sales2 and save it in the folder that holds your exercises
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	Text Editing

	


	Data that you type in a worksheet is in fact entered in cells, except when you are drawing. To use Microsoft Excel with more finesse, you should familiarize with cells, their functionality, their configuration, and their relationships with each other and with the whole software.

The primary technique you can use to get acquainted with the software is by entering data, primarily text, then manipulate various components of your application in order to customize it.

Unlike a traditional word processor, Microsoft Excel has a unique way of treating text and considering any data you type in a cell. You should be aware of the default settings that the software acts on when you type data, how it considers and treats various numbers, dates, and currency values, etc.

We have already seen how to do basic data entry into cells. The entries we used so far were short expressions consisting of one word, we need to find out whether a cell can accept text that is wider than the displayed width, if so, what happens if text goes "overboard"?
We know that data entered in a cell is confined to that cell. If you type text that is longer than the cell's width, the content will display fine, giving the impression that the text is covering more than one cell or that the cell on the right side is no more available. Data you type is always in its cell. If you type anything in a cell, its content will take priority in displaying its content; therefore the content of the left cell will appear cut. That's why you should be very familiar with the way a cell (any cell) displays its data, and how every cell relates to the others.
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Practical Learning: Entering Text Into Cells

	


	1. To start a new workbook, press Ctrl + N

2. Click cell C2 and type GRIER SUMMER CAMP
3. Click cell B5 and type Employment Application
4. Click cell F5 and type Today:
5. Click cell B8 and type First Name:
6. Press Enter

7. In cell B9, type Address:
8. Press Enter.

9. In cell B10, type City:
10. Press Tab twice.

11. In cell D10, type State:
12. Press Tab twice.

13. In cell F10, type ZIP Code:
14. Click cell B12 and type Nickname:
15. Click cell B13 and type Home Phone:
16. Press Enter.

17. In cell B14, type How Did You Hear About Us?
18. Press Enter.

19. In cell B15, type Position Desired:
20. Press Space 14 times, and type 1)
21. Press Enter.

22. In cell B16, type Desired Hourly Salary:
23. Press Enter.

24. In cell B17, type Starting Date Available:
25. Press Enter

26. In cell B18, type Available Time:
27. Click cell F18 and type E-Mail:
28. Click cell B19 and type Sunday
29. Click cell B21 and type Do You Own Transportation?
30. Click cell C25 and type Employment References And Records
31. Press Enter.

32. Click cell B27 and type Professional References
33. Press Enter.

34. In cell B28, type Please list 3 professional references who can verify your work history and performance.
35. Press Enter.

36. In cell B29, type References should not be relatives and at least two must have directly supervised you.
37. Press Enter.

38. In cell B30, type at some time in your work history.
39. Click cell B32 and type '1.
40. Press Tab.

41. In cell C32, type Name of Supervisor:
42. Click cell G32 and type Title:
43. Click cell C33 and type Company Name And Address:
44. Click cell C35 and type Company Phone Number Including Area Code And Extension:
45. To save the workbook, on the main menu, click File -> Save.

46. Since the workbook has not yet been saved, the File -> Save menu called the Save As dialog box.
Type GCS Employment Application. If the Save In combo box doesn't display MS Excel Exercises, click the arrow of the Save In combo box and locate the My Documents\MS Excel Exercises folder.

47. After making sure that the MS Excel Exercises folder displays in the Save In combo box, click the Save button.


	Techniques Of Cutting and Copying Cells Contents

	


	If you have done word processing before, you are probably familiar with techniques of cutting, copying, pasting, and/or moving text from one part of a document to another, or from one document to another. Although these techniques are available here, Microsoft Excel doesn't quite imitate a word processor. Again, spending time with the software will increase your experience.

When you copy or cut something, it goes in a temporary storage area where it will wait for you to send it somewhere else, an action called pasting. The storage area where the cut or copied data is sent is called the clipboard. In Microsoft Excel 97, you can store only one item at a time in the clipboard. If you cut or copy something, it will replace the content of the clipboard with the new selection. In Microsoft Excel 2000, the clipboard can contain up to twelve items. When the Clipboard toolbar is functional, you can select copied or cut items from its list of buttons. If you use more than 12 stored items, the toolbar functions on a first-in first-out basis.

The Clipboard toolbar can be moved to any location of your choice on the screen. You can also hide/close it if you don't need its services. For this exercise, when the Clipboard toolbar appears, don't close it. Even if you are not preparing for the MOUS exam, you should learn to take advantage of the new clipboard. In case you are not aware, you can use the same Clipboard toolbar in different applications; for example, you can have Microsoft Excel, Microsoft Access, Microsoft Word, and Microsoft Outlook all of them opened at the same time and sharing the same clipboard items. 
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Practical Learning: Cutting and Copying Cells Contents

	


	1. To open a new workbook, from the main menu, click File -> Open...

2. Click GCS Employment Application1 and click Open

3. Click cell D8, type MI: and press Enter (the MI stands for Middle Initial)

4. Right-click cell B8 and click Copy from the shortcut menu

5. Click cell F8 and press Enter. That pastes First Name to cell F8

6. Right-click cell B13 and click Copy. At this time, the Clipboard toolbar should be displaying on the screen. If you don't see it, on the main menu, click View -> Toolbars, and click Clipboard. The clipboard toolbar is new to Microsoft Office 2000

7. Click cell F13. You can check what items are on the clipboard any time. Position your mouse on the first button on the clipboard (don't click), a tool tip will appear. Move the mouse to another item and read the tool tip. On the Clipboard toolbar, position the mouse on the last copied item and it should display Home Phone
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Therefore, click that button

8. Click cell F15 and type 2)

9. Right-click cell F18 and click Cut. One more item gets copied to the Microsoft Office 2000 Clipboard

10. Click cell D12
On the Clipboard toolbar, position the mouse on the last button on the Clipboard toolbar until you see E-Mail in the tool tip, then click it

11. Select cells from B32:G35
On the Clipboard toolbar, click the Copy button [image: image162.png]


. That action copies the selected range on the Clipboard. To check that the range of cells has been copied to the Clipboard toolbar, position your mouse on the most recent button on the Clipboard toolbar and read the tool tip
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12. Click cell B38

13. On the Clipboard toolbar, click the last button to paste the copied selection. If you are using Microsoft Excel 97, press Ctrl+V

14. Select cells C38:G41. Position your mouse on the upper border of the selected cells until the mouse pointer turns into a top left pointing arrow

15. Press and hold Ctrl

16. With the mouse pointer still pointing to North West and the mouse now having a small + sign, click and hold the mouse down, then drag towards the lower side of the screen. A small yellowish box guides you to know where the selection is leading
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17. When you get to B44:G47, release the mouse, then release Ctrl

18. To save the workbook, on the Standard toolbar, click the Save button [image: image165.png]





  

	Text in Cells

	


	Editing cells content consists of deleting, replacing, altering, or adding something in them. You already know that if you click a cell and start typing, its content will be replaced with the new entry. If you want to add or subtract something to a cell's content, you can double-click it; this puts the cell in Edit mode and you can then proceed. An alternative is to give focus to a cell, then press F2, this also puts the cell in Edit mode; this time, the cursor is at the end of the text in the cell; then you can proceed. Whatever technique you use, when you have finished editing a cell, make sure you lose its focus by pressing Tab, Enter, or clicking somewhere else. When you are in Edit mode, the arrow keys are not working, and many actions are not available.
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Practical Learning: Editing Text in Cells

	


	1. Click the Sheet2 tab.

2. Double-click cell F8, press Home, press Delete three time, and type La
Now cell F8 displays Last Name.

3. Click cell F13. In the Formula Bar, double-click Home and type Work
4. Click cell B38 and type '2.
5. Click cell B44 and type '3.
6. Click cell B27, press Ctrl + C

7. Click cell B51 and press Enter

8. Press F2 to initiate editing. Edit the content of cell B51 to display Personal References
9. Click cell B52 and type Please list 2 personal references (must not be a relative)
10. Click cell B54 and type '1.
11. Press Tab and type Name and Address:
12. Click cell C56 and type Phone Number:
13. Press Enter.

14. In cell C57, type Years Acquainted:
15. In cell F57, type Occupation:
16. Press Enter

17. In cell C58, type Natural Relationship:
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18. Save the workbook

19. To close it, press Ctrl+F4


	Exploring Cells Content

	


  

	Introduction

	


	Microsoft Excel shares a lot of characteristics with window applications: the ability to search through the document for a particular word or phrase, the ability to find a word or group of words and replace it with another word or expression.

A feature unique to Microsoft Excel as a spreadsheet application is the ability to fill out some cells with values that belong to a common series. 


	Overview of AutoFill

	


	Microsoft Excel recognizes series of items so far as they can be clearly identified, either by the common language or by defining them explicitly in a worksheet. Common series include time, dates, weekdays, or months. Whenever Microsoft Excel can identify the content of a cell as being a series, you can use the Fill Handle to copy adjacent values of the series to neighbor cells. If a series is not obvious, you need to clearly define it so the application can recognize the allure you want to use for the series.

To use the AutoFill, first select a cell or the cells that define the series. Position your mouse on the lower right corner of the selected cell or cells, and then drag in the appropriate direction. 
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Practical Learning: Exploring the AutoFill

	


	1. In Microsoft Excel, press Ctrl + N to start a new empty workbook.

2. In cell B2, type 1st Qtr
3. Position your mouse on the lower right corner of the selected cell, on the squared point. This point is called the Fill Handle. Your mouse will turn into a +
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4. Click on the Fill Handle, hold the mouse down and drag in the right direction until you get to cell E2
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5. Release the mouse. Now you get 1st Qtr, 2nd Qtr, 3rd Qtr, and 4th Qtr.

6. In cell B4, type 1st Grade
7. Drag the Fill Handle in the right direction until you get to cell G4. Then release the mouse to see the subsequent grades.

8. In cell B6, type 1:00
9. Drag the Fill Handle in the right direction until you get to cell H6. Then release the mouse to see the hours displayed.

10. In cell B8, type 9:00 and drag its Fill Handle to cell H8. Notice how Microsoft Excel displays time values in subsequent cells.

11. Click cell B8 and notice the value displayed in the Formula Bar.

12. In cell B10, type 13:00 and drag its Fill Handle to H10. Notice how times get displayed in the other cells.

13. In cell B12, type 9:00 AM and drag its Fill Handle to cell H12. Notice how this time, unlike row 8, Microsoft Excel changed the AM to PM after 11:00 AM:
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14. In cell B14, type Jan and drag its Fill Handle to cell H14. Notice how the application displays months in subsequent cells

15. In cell B16, type Monday and drag its Fill Handle to cell H16. The computer displays all weekdays

16. In cell B18, type 02/24/1990 and drag its Fill Handle to cell H18. Dates incrementing each day by 1 are displaying in the other cells

17. Click the Sheet2 tab

18. Sometimes Microsoft Excel will not recognize a series with just one value, this happens when the series is not obvious. For example, if you type 1970 in a cell and drag the Fill Handle, the computer would not know whether you want to increment the number by 1, 2, 4, or 10. So you have to specify how the series will be applied. To define a series, type the beginning value, then in the subsequent cell type the incremental values or the value that will be used to define the series.
In cell B2, type 1970, press Tab

19. In cell C2, type 1974
20. Select cells B2:C2

21. Position the mouse on the Fill handle, which is on the lower right border of cell C2 (because both cells are selected). When the mouse becomes a +, drag the Fill Handle in the right direction up to cell H2. The cell values have been incremented by 1 starting on cell B2

22. In cell B4, type 1
23. In cell C4, type 2
24. In cell B5, type 0
25. In cell C5, type 2
26. In cell B6, type 0
27. In cell C6, type 3
28. In cell B7, type 100
29. In cell C7, type 101
30. In cell B8, type 100
31. In cell C8, type 125
32. Select cells B4:C8

33. Position your mouse on the Fill Handle in the lower right corner of the selected cells (in cell C8). Then drag the Fill Handle to column H and release the mouse:
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34. Notice that Microsoft Excel could figure out how to handle each series. The first was to increment numbers by 1 starting at 1. The second was asked to list even numbers starting at 0. The third gave a list of odd numbers starting at 0. The third had to count by 1 starting at 100. The fourth was going to find quarter values in a 100 number basis starting at 100

35. In cell B10, type Jan
36. In cell C10, type Apr
37. Select cells B10:C10. Drag the Fill Handle of the selected cells to cell E10. You get the first month on every quarter

38. In cell B12, type 1st Qtr
39. In cell A13, type Jan and drag the Fill Handle of cell A13 to cell C13. That will display the months of the first quarter

40. Select cells A12:C13. Drag the Fill Handle of the selected cells to cell L13

41. Save the workbook as Fill Effects
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	AutoFill Application

	


	As the AutoFill features provides a quick means of completing cells that can host series data, this feature can be applied in various scenarios.

When creating time sheets, use the weekdays and time periods to complete adjacent cells. In a yearly sales report, Microsoft Excel can recognize series such as months, quarters, and years. In a school’s spreadsheet used to collect students’ grades, a series can be created from 1st Grade, and then dragging the Fill Handle, Microsoft Excel will complete other cells with subsequent class grades.
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Practical Learning: Applying the AutoFill

	


	1. On the main menu, click Window.

2. From the list of workbooks, select GCS Employment Application2.

3. Click cell B19.

4. Position the mouse on the lower right corner of the selected cell, on the point, until the mouse pointer becomes a + sign. Click and hold your mouse down, then drag in the right direction to cell H19. That will update the weekdays.

5. Select cells B32:G37

6. Drag the Fill Handle down until the lower border aligns with the lower border of row 48 and release the mouse.

7. In cell B38, type '2.
8. In cell B44, type '3.
9. Select cells B54:F60. Position your mouse on the Fill Handle of the selection. Click and drag down until the lower border of the box you are dragging aligns with row 65, then release your mouse.

10. In cell B61, type '2.
11. Click cell C70 and type Applicant’s Signature:
12. Click cell F70 and type Date:
13. Save and close the workbook (not Microsoft Excel).


	Data Entry and Text Management

	


  

	The GoTo, Find, and Replace Dialog Boxes

	


	To locate a particular cell in Microsoft Excel, you can use the Go To dialog box. This dialog box recognizes cells names by applying the same conventions used by Microsoft Excel. You can get the Go To dialog box from the main menu under Edit.

The shortcuts to access the Go To dialog box are Ctrl + G or F5.

The Find dialog box allows you to find a word in your worksheet, either to simply locate a particular word or multiple instances of a word, or to manipulate a word or groups of words at will.

The Replace dialog box allows you to find a word or group of words and to replace it with a new word or group of words. Both dialog boxes are available from the main menu under Edit.

The shortcut for the Find dialog box is Ctrl + F.

The shortcut for the Replace dialog box is Ctrl + H.
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Practical Learning: Finding and/or Replacing Cells Content

	


	1. The GCS Employment Application2 workbook should still be opened.

2. To locate a cell, on the main menu, click Edit -> Go To...

3. Type F13 and click OK.

4. Press Ctrl + G, that calls the Go To dialog box.

5. Type C2 and press Enter.

6. To find a word in the document, on the main menu, click Edit -> Find...

7. In the Find What box, type name and click the Find Next button 8 times. Press Esc to dismiss the Find dialog box.

8. To find a word and replace it with another word, on the main menu, click Edit -> Replace...

9. In the Replace dialog box, in the Find What box, type natural and press Tab. In the Replace With box, type Nature of
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10. Click Find Next.

11. When the first instance of natural is found, click Replace. Click Replace All.

12. When all instances have been found and replaced, a message box will let you know that Microsoft Excel Cannot Find A Match.

13. Click OK on the message box.

14. Click Close on the Replace dialog box.

15. Press Ctrl + S to save the workbook.


	Check Spelling

	


	Although Microsoft Excel is not a word processor, since you can use it to create text documents such as employment applications, brochures, time sheets, etc, it can help you correct typing mistakes of various kinds. It is a good idea to check spelling mistakes in your document before printing it or sending it for an important business transaction. The check spelling is done with the help of a Spelling dialog box that will take you step by step to every word that is questionable. Also, the computer will point out some suggested words that you can use instead of the one at fault.

You can check your worksheet's spelling during or after editing, though the latter is better. To check your document, click the Spelling button on the Standard toolbar or on the main menu, click Tools -> Spelling... The shortcut to access the Spelling dialog is F7. 


	[image: image177]Practical Learning: Proof Reading the Worksheet

	


	1. Open the GCS Employment Application3.

2. On the main menu, click Tools -> Spelling...

3. From the Spelling dialog box, the first suggestion is to change the word Employement. After making sure that Employment is selected in the Spelling dialog, then click Change.

4. The next mistake is in the spelling of the word Salary. After making sure that Salary is selected in the dialog, click Change:
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5. The next problem is with the word Transportation. From the Spelling dialog box, in the list of suggested words, click Transportation and click Change.

6. Accept to Change the word References in cell B27.

7. In cell B28, accept to change performance.

8. In cell B30, accept to change the mistake with history.

9. When the dialog gets to the content of cell B50, select the word personal instead of personnel to replace personel. Then click Replace.

10. Also, correct references.

11. The last problem is with the word sinature. Accept to change it to Signature.

12. After the last problem, Microsoft Excel displays a message box asking whether you want to continue checking at the beginning of the sheet. Click Yes. Another message box should tell you "The spelling check is complete for the entire sheet." Click OK.

13. Press Ctrl + Home to get to the beginning of the worksheet.

14. Press Ctrl + S to save the workbook.


	


	Introduction to Cells Formatting

	


  

	Introduction to Cells Formatting



	

	Overview

	


From the previous lessons, you are already familiar with the way Microsoft Excel displays text (left aligned) and numbers (right aligned). In some situations, you will want to treat numbers as text. 

To display a number as text, append a single quote (') to its left. For example, to display 908 as text, type '908 in the cell where you want to display 908. The single quote will not display and will not print, but the number, treated as text, will be left aligned. 

Although Microsoft Excel displays all numbers right aligned, as a smart financial and business application, it can distinguish between different types of numbers. It can recognize a date, a currency, or a percentage values. But the computer wants you to specify the way numbers should be displayed, giving you the ability to decide what a particular number represents, not because the software cannot recognize a number, but because a value can represent different things to different people in different scenarios. For example 1.5 might represent a half teaspoon in one spreadsheet while the same 1.5 would represent somebody's age, another spreadsheet's percentage, or etc. 

Microsoft Excel can recognize some numbers by default and would not need much configuration, if any. For example, if you type 12/05/1998 in a cell, Microsoft Excel will recognize it as a date and act accordingly. 

	Introduction to Numbers Formatting

	


When it comes to displaying items, Microsoft Excel uses various default configurations, ranging from the font used by your application to the actual display of numbers in cells. The computer's Regional Options or Regional Settings govern how dates, numbers, and time, etc get displayed on your computer.

Microsoft Excel recognizes numbers in various formats: accounting, scientific, fractions, and currency. As the software product can recognize a number, you still have the ability to display the number with a format that suits a particular scenario.

Before finding out how to display numbers in different situations, you should be familiar with the way the application treats your numbers. That's why once again we will review some of the things we have already learned.

Practical Learning: Exploring Cells Number Formats

	1. Start Microsoft Excel if necessary and open the Allentown Car Sales2 workbook

2. In Sheet1, click cell B2 and type Item Code
3. Click cell B3 and type '218
4. Click cell C2 and type Make
5. Click cell H1 and type Finance
6. Press the down arrow key

7. In cell H2, type Rate
8. Complete the rest of the Allentown Car Sales2 Sheet1 as follows:
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9. To save the workbook, on the main menu, click File -> Save

10. Click Sheet2 

11. Select cells F3:F10

12. On the Formatting toolbar, click the Comma Style button [image: image181](if you don't see the Comma Style button, click the >> button on right border of the Formatting toolbar to display the other Formatting toolbar buttons, then click the Comma Style button). Now these thousand numbers display with a comma sign which makes it easier to read. Microsoft Excel also allows you to be more precise with these numbers, that's why it added two decimal values

13. Press Ctrl + Home to see the result

14. The values in the F column represent car mileage values; we don't need to display these numbers with decimal places
Select cells F3:F10 again

15. To remove the decimal values, on the Formatting toolbar, click the Decrease Decimal button [image: image182]. That removes one decimal value. Click the Decrease Decimal button again [image: image183]
16. Click cell F1 to see the result

17. Select cells G3:G10

18. In the Formatting toolbar, click the Currency Style button [image: image184]. The numbers in column G are now treated as money values and a $ sign has been appended to them

19. Select cells H3:H10. On the Formatting toolbar, click the Percent Style button [image: image185]. Now the numbers in column H are treated as percentage values

20. Our percentage numbers need a little more precision; therefore, we will display them with at least two decimal places. While cells H3:H10 are still selected, on the Formatting toolbar, click the Increase Decimal button [image: image186]twice. Notice that the numbers have changed and are now more precise:
 
[image: image187]
21. Save the workbook


	Introduction to the Format Cells

	


  

	Overview

	


	Although you can do most of cells configurations using the Formatting toolbar, Microsoft Excel provides the Format Cells dialog box. This dialog box presents more options and prec ision than the toolbar.

To display the Format Cells dialog box, you can click Format -> Cells on the main menu. You can also right-click the cell or group of cells whose format you want to change and click Format Cells. The shortcut to access the Format Cells dialog box is Ctrl + 1


	The Number Property Page

	


	The object used to manage the value of a cell or the values of a group of cells on the Format Cells dialog box is the Number property page:

[image: image188]
The left section of the Format Cells dialog box displays the Category list box. This allows you to select the type of value that the cell or group of cells contains. After selecting a category, the right section of the property page changes, depending on the category that was selected. We are going to see various options available.


	[image: image189]Practical Learning: Introducing the Format Cells

	


	1. Select cells G11:G17. We will now use the Format Cells dialog box

2. On the main menu, click Format -> Cells...

3. On the Format Cells dialog box, click the Number property page. In the Category list box, click Currency. Make sure that the Decimal Places spin button displays 2
 
[image: image190]
4. Click OK. Although all cells in column G display currency values, notice some differences with the way the first category (G3:G10) displays them as compared to the rest

5. Select cells F11:F17

6. Right-click in the selected cells and choose Format Cells...

7. From the Category, click Number. Decrease the Decimal Places spin button to 0. Click the Use 1000 Separator (,) check box:
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8. Click OK. Again, notice how numbers on column F are displayed

9. Select cells H11:H17

10. Press Ctrl + 1 which is a shortcut for Format -> Cells

11. For this section, we are going to exclusively use the keyboard.
If the Number proper page is not selected, press Ctrl + Tab a few times to switch from different property pages until the Number tab receives focus).
Press Tab once to give focus to the Category list box. Press the down arrow key a few times until Percentage is selected. Press Tab to give focus to the Decimal Places spin button; then, either using the up and down arrow keys or just typing, set the spin button to 2 (the Decimal Places spin button should already be set to 2)

12. Press Enter

13. Select cells I9:I13.

14. The dates can also be displayed in various formats. You can make your selection from the Format Cells dialog box in the Date category.
Press Alt, press o, press E.

15. In the Category list, make sure Date is selected, in the type list, using either the keyboard or the mouse, select March 14, 1998. Click OK
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16. Save the workbook.


	Special and Custom Formats

	


	Although Microsoft Excel can recognize number formats of various kinds, sometimes none of the preset formats will suit a particular need you have for a certain cell or group of cells. You can use either one of the Special Formats or create your own.

The Special formats can be accessed from the Format Cells dialog box. These formats allow you to specify a cell or column for US ZIP Codes (5 or 5+4 number digits), phone numbers, or Social Security Numbers.

To create your own custom format, from the Format Cells dialog box, click the Custom category, select one of the existing formats, then proceed to create your own by adding appropriate or subtracting undesired characters.

If you get to using a worksheet that was prepared by someone else (or you) and find out that the format used by a cell or some cells is not appropriate, you can change it using the Format Cells dialog. Right-click the appropriate cell (s) or column (s) and choose Format Cells. In the Category list, select one and in the right list, select the format you like.


	[image: image193]Practical Learning: Using Special and Custom Formats

	


	1. To start another workbook, Click the New button [image: image194]on the Standard toolbar.

2. In cell H1, type Age Structure
3. In cell J1, type Life Expectancy at Birth
4. In cell A2, type Country
5. In cell B2, type Area
6. In cell C2, type Population
7. In cell D2, type Government
8. In cell E2, type Independence
9. In cell F2, type US Contact
10. In cell G2, type Teens
11. In cell H2, type Adults
12. In cell I2, type Seniors
13. In cell J2, type Total
14. In cell K2, type Male
15. In cell L2, type Female
16. Save the workbook as World Statistics1 in your exercises folder

17. Select columns B and C. Right-click column B (on the selection) and click Format Cells... In the Format Cells dialog box, click the Number property page. In the Category list, click Number. Set the Decimal Places to 0. Click the Use 1000 Separator (,) check box to check it. Click OK.

18. Right-click column F and click Format Cells... From the Number property sheet, click Special. In the Type list, click Phone Number
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19. Click OK.

20. Select columns G, H, and I. 

21. Press Ctrl + 1. From the Number property page, in the Category list, click Percentage. Set the Decimal Places to 0. Click OK.

22. Complete the World Statistics worksheet.

23. To save the workbook, press Ctrl + S.

24. To open an existing workbook, press Ctrl + O.

25. In the Open dialog box, double-click GSC Employees1. Notice that the cells in column B have been to configured to display employees numbers with a period (.) after the first 2 number digits.

26. To clear a format that is set on some cells, right-click column B and click Format Cells...

27. In the Format Cells dialog box, in the Category list box of the Number tab, click General and click OK. Now, the numbers display regularly.

28. To use a special preset format, right-click column H and click Format Cells...

29. From the Number property sheet, in the Category list, click Special. In the Type list, click Phone Number. Click OK.

30. To use a custom format, we will change the way dates in column G display. Instead of 04/14/89, we prefer 14-Apr-89.
Right-click column G, and click Format Cells...

31. In the Category list, click Custom. In the Type list, click d-mmm-yy
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32. Click OK. Notice how dates display now.

33. Now we will configure how employees numbers display. Instead of 38002, we will display 38-002. To achieve that, we will create our own format.
To create a custom format, right-click column B and click Format Cells... 

34. In the Category list, click Custom. In the Type list, click #,##0.

35. In the text box under Type:, click and edit the content to display
0#-##0

36. Click OK. Notice how the employees numbers display now
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37. Save the workbook.

 


	The Computer's Regional Settings

	


	Many settings that control how your computer displays dates, time, and other numbers are configured in the system Registry and controlled by the computer itself. This makes sure that your computer is in tune with the language you use in your computer experience and certainly keeps you synchronized with your computer neighbors.

The computer's Regional Settings can be viewed and/or changed from the Control Panel by double-clicking the Regional Settings icon.


	[image: image198]Practical Learning: Checking the Computer's Regional Settings

	


	1. From the Taskbar, click Start -> Settings -> Control Panel

2. In Control Panel, double-click Regional Options or Regional Settings

3. Click the General property page. Check the language that your computer is using

4. Click the Number property sheet. Examine how the numbers are configured for your computer. Here is an example:
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5. Click the Currency property sheet. Check how the money value is set to display in your computer.

6. Click the Date property page. Check how dates are set to display in your computer:
  

[image: image200]
7. Click the Time property sheet. Review how the numbers are set to display in your computer.

8. When you have finished examining the property sheets, click Cancel (unless you want to save or apply the changes you might have made, in which case you would click OK).

 


	Text And Cells Formatting: AutoFormat

	


	A good worksheet is not simply determined by its functionality, its look plays a great deal and reflects your tastes in fonts, styles, and design. Before we experiment with its design capabilities, we will first find out how Microsoft Excel can help with choosing fonts, font styles, sizes, and colors.

Cell formatting allows you to control how text displays in your cells, how much room various columns and rows need in order to display their content. Microsoft Excel ships with sample table with each configured to suit a specific scenario. Whenever possible, or you are simply in a hurry, use one of these readily available samples; one of the sample AutoFormat tables can make your table or part of your worksheet look professional.

To use the AutoFormat, first select the cells you want to format; then on the main menu, click Format -> AutoFormat... From the AutoFormat dialog box, select the style you want and click OK. You can change your style any time and many times until you are satisfied.


	[image: image201]Practical Learning: Using AutoFormat

	


	1. From the Taskbar, click Microsoft Excel and start a new workbook

2. In Sheet1, click cell B5 and type Robert
3. Click cell C4 and type January
4. Complete the worksheet as follows:
  

  

January

February

March

April

May

June

Robert

2600

3450

2860

3840

3250

3480

Lucy

3580

3420

3550

2860

3640

3520

Annette

460

1240

1850

2380

2650

2870

Josiane

840

650

520

720

550

480

Salif

620

580

610

560

820

520

5.   

6. Save the workbook as Alexandria Furniture1

7. Press Ctrl + A to select all cells

8. Press Ctrl + C to copy

9. Click Sheet2 and press Ctrl + V to paste the selection.

10. Click Sheet 3 and press Ctrl + V to paste again

11. Click Sheet1 and press Esc

12. In Sheet2, select cells B4:H9.

13. On the main menu, click Format -> AutoFormat...

14. From the AutoFormat dialog box, click Classic 2
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15. Click OK.

16. Press Ctrl + Home see the result.

17. Click Sheet3

18. Select cells B4:H9

19. On the main menu again, click Format -> AutoFormat...

20. From the AutoFormat dialog box, click List 1

21. Click the Options... button

22. Click the Width/Height check box to remove the check mark
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23. Click OK and press Ctrl + Home to see the result

24. Select cells C5:H9.

25. On the Formatting toolbar, click the Currency Style button [image: image204]. Now the numbers display appropriately as sales values.

26. On the Formatting toolbar, click the Decrease Decimal button [image: image205]twice to remove the decimal places on the sales numbers.

27. On the main menu, click Tools -> Options...

28. From the Options dialog box, click the View property page.

29. In the Window Options section, remove the check mark of the Gridlines check box
 
[image: image206]
30. Click OK.

31. Save your workbook.

	


	Formatting Cells Contents

	


  

	Cell Alignment 


	

	  

Cells Merging

When reviewing cells, we found out that a cell doesn't have dimensions of its own. Its width is imposed by its parent column and its height is set on its parent row. All of the cells we have used so far were considered individually. Microsoft Excel allows you to combine various cells in a group. This is referred to as merging cells.

To merge cells, select them and, on the Formatting toolbar, click the Merge and Center button.

Practical Learning: Merging Cells

1. Open the DAWN Report2 workbook and click Sheet2 to make it active

2. Select cells A3:D3

3. On the Formatting toolbar, click the Merge and Center button [image: image208]
4. Select cells F3:I3

5. Press F4 to repeat the last action (otherwise, on the Formatting toolbar, click the Merge and Center button [image: image209])

6. Press Ctrl + Home

7. To save the workbook, press Ctrl + S

Cells Content Alignment

We have already seen how Microsoft Excel differentiates data you enter into cells. Sometimes its default configurations will not suit your particular scenario, you should be able to control how text is aligned in cells.

Since a cell is really a rectangular box, you can completely control how text is displayed inside of it: left, right, top, bottom. As we move on, we will see various situations of aligning cells content. 

Practical Learning: Control Cells Alignment

1. Open the Cherry Pumpkin Day Care1 workbook

2. To control the alignment of one cell, click cell F4 to make it active

3. On Formatting toolbar, click the Align Right button [image: image210]
4. To control the alignment of a group of cells, select cells E5:E15

5. On the Formatting toolbar, click the Center button [image: image211]
6. To control the alignment of all cells under a column, click column header C

7. On the Formatting toolbar, click the Center button [image: image212]
8. Press Ctrl + Home and press Ctrl + S to save the workbook

9. Open the DAWN Report2 workbook

10. In Sheet1, randomly select cells C6, D5, D6, H6, I5, and I6 (press and hold Ctrl while you are clicking each cell)

11. To control the alignment of a group of randomly selected cell, on the Formatting toolbar, click the Center button [image: image213]
12. Select cells A7:A16

13. On the Formatting toolbar, click the Align Right button [image: image214]
14. Select cell F7:F16 and press F4 to repeat the last action

15. Save the workbook
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	Cells Content Indentation

	


	In the previous section, we used the Center button to center the content of a cell with regards to the width of the cell. In some circumstances, you may not want to center text but you would not like to keep it left or right aligned. Indentation consists of "pushing" text to the left or the right without centering it.

To indent the contents of a cell or of a group of cells, after making the selecting, on the Formatting toolbar, you can use the Increase Indent button to "push" the contents of a cell or a group of cells to the right. The Decrease Indent button produces the same effect in the left direction.


	[image: image225]Practical Learning: Indenting Cells Content

	


	1. Open the Grier Summer Camp2 workbook and, if necessary, click Sheet1

2. Click cell C5 to make it active

3. On the Formatting toolbar, click the Increase Indent button [image: image226]
4. Click cell D6 and press F4 to repeat the previous action


	The Alignment Property Page

	


	Besides using the alignment buttons on the Formatting toolbar, to be more precise or to perform various actions in one step, you can use the Alignment property page of the Format Cells property sheet:

[image: image227]
To provide the same options as the Formatting toolbar, the Alignment property page is equipped with the Horizontal combo box. Besides the left, center, and right alignments, this combo box goes further and allows text to be justified. This can be useful especially if the text is significantly long. If you select to indent text, you can use the Indent spin button to specify the number of units to indent by.

The Vertical combo box provides options not available on the Formatting toolbar. It allows you to align the contents of a cell towards the top, the middle or the bottom area of a cell.

The Text Control section provides three options: Wrap Text, Shrink To Fit, and Marge Cells.

The Orientation section allows you to "bend" text by a fix angle. There are two main ways you can set an angle. If you drag the small red diamond, you can use it to specify the desired angle. You can also click one of the arrows of the Degrees spin button.


	[image: image228]Practical Learning: Using the Alignment Property Page

	


	1. Sheet1 of the Grier Summer Camp2 workbook should still be selected
Select cells B9:C10

2. On the main menu, click Format -> Cells...

3. In the Format Cells dialog box, click the Alignment property page

4. In the Text Control section, click the Merge Cells check box, and click OK

5. Select cells E9:H9 and press F4 to repeat the previous action

6. Select cells E8:H8

7. Right-click the selection and click Format Cells...

8. In the Alignment tab of the Format Cells dialog box, in the Horizontal combo box, select Center

9. In the Vertical combo box, select Center

10. In the Text Control section, click the Merge Cells check box
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11. Click OK

12. Select cells A11:A26

13. Press Ctrl + 1 to call the Format Cells dialog box

14. In the Horizontal combo box, select Right

15. In the Text Control section, click the Merge Cells check box

16. In the Orientation section, click and hold the mouse on the small red diamond. Then drag it up until the spin button in the same section displays 90
  

[image: image230]
17. Click OK


	Cells Borders 

	


  

	Introduction

	


	The alignment we have used so far is applied to the contents of a cell or of a group of selected cells. As we have mentioned already, a cell appears and behaves like a rectangular box. As such, it has borders and a background. Microsoft Excel provides a default appearance for a cell with regards to its background. For example, it surrounds the cell with a gray border and a white background. You can keep these defaults or you can change them as you see fit.

Once again, to format a cell, you can use the Formatting toolbar. It is equipped with the Borders button. To change the borders of a cell or a group of cells, first select it. If the Borders button already displays the type of border you want, you can just click it. Otherwise, to select a type of border, you can click the arrow of the Borders button. It would display a window with preset borders:

[image: image231]
To help with recognizing  borders, each button displays it own tool tip. To find it out, you can position the mouse on a button for a few seconds. From now on, we will refer to each button or border by its tool tip.

Once you see a border you like, you can click it. After clicking a preset, the Borders window closes and the button becomes as it was before. The clicked border would become the default selection on the Borders button. If you are doing a lot of borders formatting, you can click the arrow of the Borders button to display its window. Then, on the Borders window, you can drag its blue bar away from the toolbar. This would keep the Borders window permanently opened. Once you don't need it anymore, you can close it as you would close any window.


	[image: image232]Practical Learning: Adding Borders to Cells

	


	1. The Grier Summer Camp2 workbook should still be opened with the Sheet1 selected
Select cells B2:J2

2. On the Formatting toolbar, click the arrow of the Borders button and click the Top And Double Bottom Border button (3rd column - 2nd row)

3. Select cells F6 and G6

4. On the Formatting toolbar, click the arrow of the Borders button and click the Bottom Border button
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5. Randomly select cells F5:G6 and I29. Press F4 to repeat the previous action

6. Select cells I6:J6

7. On the Formatting toolbar, click the arrow of the Borders button and click the Top And Bottom Border button

8. Select cells A9:A27

9. On the Formatting toolbar, click the arrow of the Borders button and click the Right Border button

10. To see the result, on the main menu, click Tools -> Options

11. In the Window Options section, remove the check mark on the Gridlines control and click OK
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12. Save the workbook

13. Open the DAWN Report2 workbook

14. Click cell A3 to give it focus.

15. On the Formatting toolbar, click the arrow of the Borders button. Click the Bottom Border (second column, first row)
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16. Click cell F3 and press F4 to repeat the last action

17. Select cells A6:I6

18. Since the bottom border is already selected on the Borders button, on the Formatting toolbar, just click the Borders button

19. Save the workbook


	The Border Property Page

	


	You may realize soon that, despite its list of patterns, the Borders button of the Formatting toolbar has some limitations. Normally, it was created to provide the most regularly applied borders. To apply more options, the Format Cells dialog box provides the Border property page:

[image: image236]
 


	[image: image237]Practical Learning: Using the Border Property Page

	


	1. The DAWN Report2 workbook should still be opened
Select cells A17:I17

2. Right-click on the selected cells and click Format Cells...

3. From the Format Cells dialog box, click the Border property page

4. From the Line section, in the Style list box, click the 5th line in the right section of the list

5. Click the Color combo box and select Brown

6. From the Presets section, click the bottom border button
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7. Click OK.

8. Select cells A2:I2.

9. On the main menu, click Format -> Cells...

10. You should be in the Border property page (because Microsoft Excel remembers the last tab you used). From the Line section, in the Style list box, click the 6th line on the right section of the list.

11. Click the Color combo box and select Light Blue. From the Border section, click the top border button.

12. Click the Color combo box and select Indigo. From the Border section, click the bottom border
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13. Still in the Format Cells dialog box, click the Patterns property page

14. In the Color: section, click the Pale Blue color (6th column, 5th row in the list).

15. Click OK

16. On the main menu, click Tools -> Options... From the Tools dialog box, click the View property page

17. In the Window Options section, remove the check mark on the Gridlines check box, and click OK

18. Press Ctrl + Home. That will give you a better view of the work done

19. Save the workbook.


	The Cell's Background 

	


  

	Introduction

	


	The cell background is the color or pattern that fills its inside. The default background of a cell is white. There are various options available to you if you want to change it.

Once again, the Formatting toolbar provides the quickest means of configuring a cell or a group of cells. To paint a cell or a group with a color other than white, after selecting it, you can click the arrow of the Fill Color button.


	The Pattern Property Page

	


	As we have seen so far, the Format Cells dialog box provides an extensive array of options for cell configuration. It is equipped with the Patterns property page that displays a wide range of colors: 
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To change a cell background, use one of the colors on the Cell Shading section of the Patterns tab. It offers a list of colors you can use to configure a cell’s background by changing the Cell Shading.


  

	


	Style and Conditional Formatting

	


  

	Formatting With Style

	Introduction

	


	In the previous lesson, we reviewed various techniques of formatting cells. Microsoft Excel provides a faster and customized technique used to to apply a particular and user-created format that can be applied to a series of cells. As effective as that technique is, it has its own limitations. For example, it cannot create merge-and-center-related styles. Therefore, you should already remember the basic means of cells formatting, which include using either the Formatting toolbar or the Format Cells dialog box. As a reminder, we will review them here. 


	[image: image242]Practical Learning: Formatting With Styles

	


	1. Start Microsoft Excel and fill out Sheet1 as follows:
 
[image: image243]
2. Once you have finished, press Ctrl + A to select the whole worksheet and press Ctrl + C to copy

3. Click Sheet2, press Ctrl + Home, and press Ctrl + V to paste

4. Save the workbook as Styles1
5. In Sheet2, right-click cell B2 and click Format Cells...

6. On the Format Cells dialog box, click the Font property page

7. In the Font list, select Garamond. On the Font Style list, click Bold. In the Size list, click 12. Click the arrow of the Color combo box and select Blue
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8. Click OK on the Format Cells dialog box

9. Using the Formatting toolbar, change the font of INDUSTRY DEPARTMENT to Times New Roman. Change its font size to 11 and make it bold [image: image245]
10. Again, using the Formatting toolbar, Set the following cells contents to Bold [image: image246]: SEMESTER, GRADE, Student #, and Full Name 

11. Click cell B27 to select it, then make it bold [image: image247]. While cell B27 is still selected, on the main menu, click Format -> Column -> AutoFit Selection 

12. Select cells D7:E7. Right-click in the selection and click Format Cells... 

13. On the Format Cells dialog, click the Alignment property page. On the Horizontal combo box, select Center. On the Vertical combo box, select Center. In the Text Control section, click the Merge Cells check box

14. Click OK

15. Select cells B7:B8 and press F4 to repeat the last action

16. Select cells I7:J8 and press F4

17. Select cells B7:J8 and press Ctrl + 1 to open the Format Cells dialog box

18. Click the Font property page. In the Font Style combo box, click Bold. In the Color combo box, select White (8th column - 5th row)

19. Click the Border tab. In the Line Style section, click the thin line (1st column - 7th row). In the Color combo box, select White. In the Presets section, click the Inside button

20. Click the Patterns property page and, in the Color section, click Gray-50% (8th column - 2nd row)

21. Click OK

22. In the new gray section, click each of the cells that were not centered and, using the Center button of the Formatting toolbar, center them:
 
[image: image248]
23. Save the workbook 


	Cells Formatting With Styles

	


	A formatting style is a set of font, font size, color, and patterns designed to make a worksheet or one of its sections look good. Microsoft Excel is equipped with categories of styles. You can use those ones or create your own.

When applying a style, you decide to format various cells at the same time using a category of style that has been predefined. Therefore, you apply such a style to a cell or range of cells. By default, when you are typing data in a worksheet, you are already using a predetermined style made of a certain font (Arial), a font size (10), a border, and background, etc. You can modify this style or create a new one.

You select, create, or define a style using the Style dialog. The Style dialog is available from the Format menu


	[image: image249]Practical Learning: Formatting With Styles

	


	1. In Sheet2, press Ctrl + A and press Ctrl + C to copy the whole worksheet

2. Click Sheet3. Press Ctrl + Home and press Ctrl + V to paste

3. In Sheet3, click cell B9 to give it focus.

4. On the main menu, click Format -> Style…

5. Type Odd Grades to replace the style name and click Modify…

6. On the Format Cells dialog, click the Font tab. Change the font to Tahoma, Bold, size 10.

7. Click the Border property page

8. In the Line Style section, click the thin line (1st column, 7th row)

9. Click the Color combo box and select Indigo (7th column, 1st row)
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10. In the Border section, click the right border

11. Still in the Border property page, in the Line Style section, click the double line (2nd column, 7th row)

12. In the Border section, click the left border
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13. On the Format Cells dialog, click OK

14. On the Style dialog, click OK.

15. Click cell B10 to give it focus.

16. On the main menu, click Format -> Style…

17. Type Even Grades to replace the style name and click Modify…

18. On the Format Cells dialog box, in the Border property page, in the Line Style section, click the thin line (1st column, 6th row). Click the Color combo box and select Indigo (7th column, 1st row). In the Border section, click the right border.
In the Line Style section, click the dotted line, just under None. In the Border section, click the top and the bottom borders.
In the Line Style section, click the double line. In the Border section, click the left border
 
[image: image252]
19. Still in the Format Cells dialog box, click the Font property page. Set the font to Tahoma, Bold, 10

20. Click the Patterns property page. In the Cell Shading section, click Tan (2nd column, 5th row)

21. On the Format Cells dialog, click OK

22. On the Style dialog, click OK

23. To apply an existing or already created style, click cell B11 to make it active.

24. Press and hold Ctrl. Click cells B13, B15, B17, B18, B19, B21, B23, B25, B27, B29, B31, B32, B33, and B35. Release Ctrl.

25. On the main menu, click Format -> Style…

26. On the Style dialog, click the arrow of the Style Name combo box and select Odd Grades, and click OK.

27. Click cell B12 to give it focus.

28. Press and hold Ctrl. Click cells B14, B16, B20, B22, B24, B26, B28, B30, and B34. Release Ctrl.

29. On the main menu, click Format -> Style…

30. On the Style dialog, click the arrow of the Style Name combo box and select Even Grades, and click OK

31. Press Ctrl + Home to see the result
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32. Start a new workbook and, in Sheet1, enter the following data
 
[image: image254]
33. Save the workbook as Red Oak High School
34. In Sheet1, press Ctrl + A and Ctrl + C

35. Click Sheet2. Press Ctrl + Home, then press Enter


	Conditional Formatting

	


	Conditional Formatting allows you to define and apply formatting to some cells, text, and numbers based on criteria that you set. For example, you can format a time sheet to point out whenever an employee gets overtime. You can also use it to track the best sales people in a company by setting a quota that makes a cell range particular.

To use, define, and apply conditional formatting, first select the cells that will be considered. On the main menu, click Format -> Conditional Formatting... You can use any criteria of your choice. The formatting could be applied to cells' values or a particular formula.


	[image: image255]Practical Learning: Conditionally Format Cells Contents

	


	1. In Sheet2 of the Red Oak High School1 workbook, select cells C3:G10.

2. On the main menu, click Format -> Conditional Formatting...

3. We are going to set as bad any grade that is under 12.50, then we will make it obvious on the worksheet.
In the Condition 1 combo box, make sure the combo box displays Cell Value Is. 

4. Click the arrow of the second combo box and select Less Than. Press Tab.

5. In the right combo box, type 12.50

6. Click the Format... button. Set the Font Style to Bold. Click the Color combo box and select Red (1st column, 3rd row).

7. In the Format Cells dialog box, click OK
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8. In the Conditional Formatting dialog box, click OK.

9. Press Ctrl + Home to see the result

10. Now we will set as excellent any grade that is above 15 and point it out. We will add the second conditional formatting to the first.
Select cells C3:G10

11. On the main menu, click Format -> Conditional Formatting...

12. In the Condition 1, make sure the combo box displays Cell Value Is.

13. Click the Format... button. In the Font Style list, click Regular. In the Format Cells dialog box, click OK.

14. In the Conditional Formatting dialog, click the Add >> button.

15. Make sure that the Condition 2's combo box displays Cell Value Is.

16. Click the combo box on the right of Condition 2 and select Greater Than. Press Tab and type 15.

17. Click the bottom Format... button.

18. In the Format Cells dialog box, set the Font Style to Bold. Click the Color combo box and select Green (4th column, 2nd row).

19. In the Format Cells dialog box, click the OK
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20. In the Conditional Formatting dialog box, click OK

21. Press Ctrl + Home to see the result:
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22. Save the workbook

	


	Graphics And Drawing

	


  

	Introduction


	

	Microsoft Excel is equipped with drawing features that can be used to embellish a worksheet. If you have used Microsoft Office long enough, you are probably aware of its drawing tools. They allow you to draw lines, other geometric shapes, and various flowcharts, connectors, banners, etc.

Practical Learning: Formatting Cells Content

1. Start Microsoft Excel and open the Red Oak High School3 workbook.
If necessary, click the ROSH worksheet to select it.

2. Select cells A1:C25

3. On the Formatting toolbar, click the arrow of the Fill Color button and select Pale Blue

4. Click column A to select it. Press and hold Ctrl, then click column C, and release Ctrl. That selects those two columns

5. Right-click column A and click Column Width…

6. Type 0.50 and click OK

7. Click cell B17 and type Red Oak High
8. Press Enter. In cell B18, type School
9. Press Enter. In cell B19, type Student Grade
10. Press Enter. In cell B20, type Book
11. Press Enter. In cell B21, type Mrs. Arlington
12. Press Enter. In cell B22, type The Student
13. Press Enter. In cell B23, type Administrator
14. Select cell B17:B23

15. On the Formatting toolbar, click the arrow of the Font Size combo box and select 8

16. On the same toolbar, click the Center button

17. Click the arrow of the Fill Color button and select Sky Blue

18. Click the arrow of the Font Color button and select White

19. While the cells are still selected, press Ctrl + 1 which is a shortcut for the Format Cells dialog.

20. In the Format Cells dialog, click the Borders property sheet. In the Line Style list, click the last line under None

21. Click the Color combo box and select White. In the Border section, click the top, the left, the right, and the bottom borders
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22. Click OK.

23. Select cells B1:B25

24. On the main menu, click Format -> Cells to access the Format Cells dialog

25. In the Line Style section, click the 5th line on the second column

26. Click the Color combo box and select Teal

27. In the Border section, click the left and the right borders.

28. Click the Patterns property page. From the Cell Shading Color list, click Indigo (7th column, 1st row)

29. Click OK

30. Right-click column B and click Column Width

31. Type 9.50 and press Enter then press Ctrl + Home to see the result
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32. Save the workbook
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	The Drawing Toolbar

	


	The drawing in mainly done using the Drawing toolbar.

[image: image268]
The Drawing toolbar is usually available on the bottom section of Microsoft Excel’s interface. If you don’t see it or to display and hide it anytime, right-click any button on any displayed toolbar. If Drawing has a check mark, this means that the Drawing toolbar is currently displaying on your screen. To hide it, you can click Drawing and the toolbar would disappear. If Drawing doesn’t have a check mark, you can then click it to reveal the Drawing toolbar. You can also get access to any toolbar by using the main menu where you would click View -> Toolbars, then proceed the same way as described above. Another way you can control the toolbars is from the main menu where you would click Tools -> Customize.

Although the Drawing toolbar is dockable, which means you can position it on the top, on the left, or on the right sides of your screen, it is better to keep at its default and usual position, which is at the bottom of your screen.


	[image: image269]Practical Learning: Displaying the Drawing Toolbar

	


	· To display the Drawing toolbar, on the main menu, click View -> Toolbars
If the Drawing item has a check mark, then press Esc three times. If it doesn't, then click it


	Shapes

	


	A shape is an aesthetic figure you draw on a worksheet. There is no strict rule that defines what a shape looks like. 

To draw a shape, click it on the Drawing toolbar, then on the worksheet, click one of the extreme end, drag to the other extreme, when you get a satisfying size and orientation, release the mouse. Once you release the mouse, the object will still be selected with various object handles of various sides and corners of the object. If you position your mouse on different handles or on the object, the mouse pointers will have different shapes.


	 
	This shape

Allows you to
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Move the whole object
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Resize the object vertically

[image: image272]
Resize the object horizontally

[image: image273]
Resize the object in up-left down-right orientation

[image: image274]
Resize the object in down-left up-right orientation

[image: image275]
Reorient an AutoShape




	Some objects don’t display all these mouse pointers and some may display different mouse shapes. If/when one of those unusual pointers comes up, you will be guided on its meaning.

Almost any shape you draw has a marking rectangular box around it. This allows you to work on the shape as an object. For example, you can use this box to move the object.
You can move any object to a new location on your screen. Sometimes you will want to select more than one object to manipulate the group. To select more than one object, click one of them, press and hold Shift, and click the other object(s). When you have created the group, release Shift.

A drawn object can be copied and pasted to another location on the same worksheet or to a different worksheet on the same workbook, in another workbook, or even to another file. To copy an object, click it. Then on the main menu, click Edit -> Copy, and proceed with pasting. You can copy one object or a group of objects. Using the new Clipboard toolbar of Microsoft Office 2000, you can copy up to 12 objects at once, then paste them to their new respective locations. Just keep in mind that these objects will not have explicit names.


  

	Microsoft Office WordArt

	


	A Microsoft Office WordArt is a fancy formatted sentence whose features you can use to include a good-looking group of words that you type and embed in your worksheet.
To get a WordArt, you can click the Insert WordArt button on the Drawing toolbar. From the WordArt Gallery dialog, select the style you like and click OK. Type the desired sentence; you can also change the font and/or font size before clicking OK. Once the WordArt has been created, you can move and resize it to your satisfaction.

Whenever the WordArt is selected, the WordArt toolbar should be on your screen, this toolbar is very useful and you should always have it handy whenever you are working on a WordArt.
Even after the WordArt has been created, you can change its wording and style. To control its text, when the WordArt is selected, double-click or right-click it and click Edit Text, rephrase the words and click OK. To change the WordArt style, click the WordArt Gallery button the WordArt toolbar, select a new style and click OK.


	Practical Learning: Creating WordArt

	


	1. On the Drawing toolbar, click the Insert WordArt button [image: image276]
2. Click the WordArt on 5th column, 2nd row
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3. Click OK

4. Change the Size combo box to 20

5. Replace the text with Montgomery School and click OK

6. While the WordArt is selected, resize and move it to occupy the upper section of the screen
 
[image: image278]
7. On the WordArt toolbar, click the Edit Text… button.

8. Click between both words and type County Public so that when you finish, the text will read Montgomery County Public School
 
[image: image279]
9. Click OK

10. On the WordArt toolbar, click the WordArt Gallery button [image: image280]
11. Click the WordArt on 2nd column, 2nd row

12. Click OK

13. Press Ctrl + Z to undo

14. Resize and re-position the title as you see fit but somewhere in the top-left section of the worksheet
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15. Save the workbook


	Drawing Lines

	


	One of the shapes available to improve your worksheet is the line. You can draw a horizontal, vertical, or diagonal line. When drawing lines, you can control their width, color, and arrow orientation if you decide to be fancy.

To draw a line, click it on the Drawing toolbar. Then, on your worksheet, click one of the line’s intended starting points and drag on the other side, when you get the desired length or orientation, release the mouse. To draw a line starting at its center, press and hold Ctrl while you are dragging. To draw a controllable line, for example horizontal or vertical, press and hold Shift while you are dragging.

When you have just released the mouse, the drawn line is terminated by small boxes on both sides. Use these object handles to control the line’s size and orientation.


	Practical Learning: Drawing and Controlling Lines

	


	1. On the Drawing toolbar, click the Line button.

2. To draw a horizontal line, press and hold Shift. Click around the left border of cell B5 and hold your mouse down. That marks the starting point of our line.

3. Drag the mouse in the right direction until you get to the right border of cell I5, then release the mouse. You don’t have to be absolutely precise since you can still resize and move the line to meet your satisfaction.

4. While the line is still selected, on the Drawing toolbar, click the arrow of the Line Color button and click More Line Colors…

5. From the Colors dialog, click the Custom property page

6. Change the values of the colors to Red: 204, Green: 102, Blue: 0. Click OK

7. On the Drawing toolbar, click the Line Style button and select the 3rd line from bottom (4 ½ pt)
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	Microsoft Office Drawing Shapes

	


	The Drawing toolbar is equipped with numerous shapes, some of which you are familiar with, and you will get acquainted with some others. The drawing shapes on the Drawing toolbar are essentially organized in two categories. The most classic ones are readily on the toolbar; these are the Line, the Arrow, the Rectangle, and the Oval. The Line is just used to draw familiar lines. The Arrow is used to draw fancy lines terminated on one side or on both with an arrow or a bullet. The Rectangle is used to draw a rectangle or a square (a four-sided geometric figure whose sides are all equal).

To draw a regular rectangle, click the Rectangle button. On the worksheet, click one intended corner of the rectangle and hold your mouse down. Drag to the other end corner of the rectangle and release the mouse. When you get the size you want, release the mouse. If the size and the position are not satisfying, you can resize and move the rectangle to your liking, using the rectangle’s handles. To draw a rectangle starting at its center instead of its corner, press and hold Ctrl while you are dragging. To draw a rectangle starting at the corner of a cell, press and hold Alt while you are dragging.

To draw a square, press and hold Shift while you are dragging. To draw a square starting at its center instead of its corner, press and hold Ctrl + Shift while you are dragging. To draw a square starting at the corner of a cell, press and hold Shift + Alt while you are dragging.

The Oval is used to draw an ellipse or a circle. Apply the techniques we have reviewed for the rectangle, just keep in mind that this time, the shape is circled.

Other drawing shapes are available from the AutoShapes on the Drawing toolbar; these are organized in sub-categories of Lines, Basic Shapes, Block Arrows, etc.


	[image: image283]Practical Learning: Drawing Shapes

	


	1. Click the Student Info sheet to make it active

2. On the Drawing toolbar, click AutoShapes -> Basic Shapes -> Octagon

3. On the worksheet, click on the left side of cell A7

4. Resize the shape to fit the dark gray area

5. While the shape is still selected, on the Drawing toolbar, click the arrow of the Fill Color button and click Fill Effects…

6. In the Fill Effects dialog box, make sure you are in the Gradient property page. In the Shading Styles section, click From Center

7. In the Variants section, make sure that the first button (1st column, 1st row) is selected Click OK.

8. On the Drawing toolbar, click the arrow of the Line Color button, and click No Line

9. On the Drawing toolbar, click the Rectangle button

10. Click above the letter R of the RED OAK title in the upper section of the worksheet
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11. Type RED OAK HIGH SCHOOL 

12. Select the new typed words in the rectangle

13. On the Formatting toolbar, change the Font to Garamond and the Font Size to 20, also click the Bold button

14. Resize the rectangle to display all the typed words

15. Right-click the border of the rectangle and click Format AutoShape

16. From the Format AutoShapes dialog box, click the Font property page, change the Color to White

17. Click the Alignment property page

18. In the Text Alignment section, change the Horizontal and the Vertical combo boxes to Center each

19. Click the Colors And Lines property page

20. In the Fill section, click the Color combo box and select No Fill
21. In the Line section, click the Color combo box and select Light Yellow (3rd column, 5th row)

22. In the Dashed combo box, make sure that the Solid (continuous) line is selected, decrease the line Weight spin button to 0.5 pt

23. Click the Size property page

24. In the Size And Rotate section, set the Height spin button to 0.4”

25. In the Width spin button, type 3.54 and press Tab. Make sure the Rotation spin button is set to 0°. 
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26. Click OK

27. On the Drawing toolbar, click AutoShapes -> Basic Shapes -> Rounded Rectangle

28. Draw and size a shape that completely covers the former shape, the RED OAK HIGH SCHOOL title

29. While the shape is still selected, on the Drawing toolbar, click the arrow of the Fill Color button and click Fill Effects…

30. In the Fill Effects dialog, click the Texture property page

31. In the Texture list, click Brown Marble (3rd column, 2nd row). Click OK

32. On the Drawing toolbar, click the arrow of the Line Color, and select White

33. On the Drawing toolbar, click the Line Style button, and click 1 pt

34. While the shape is still selected, on the Drawing toolbar, click Draw -> Order -> Send Backward. Now both shapes should be visible

35. While one of the shapes is still selected, press and hold Shift, click the other shape (the rectangle with RED OAK), and release Shift when both shapes have been selected

36. On the Drawing toolbar, click Draw -> Align Or Distribute -> Align Center

37. While the shapes are still selected, move the whole group so that the left border of the brown marble aligns with the left border of column B

38. Click somewhere else to deselect the shapes. Press Ctrl + Home
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39. Click the ROSH Cover worksheet to select it

40. Click the lower right border of the triangle to select its shape

41. Press and hold Shift, click RED on the big text, click the wide rectangle at the bottom section of the screen, then release Shift. That selects these three shapes

42. On the main menu, click Edit -> Copy

43. Click the ROSH worksheet to make it active

44. On the main menu, click Edit -> Paste

45. While the shapes are still selected, move them on the top section

46. Click somewhere else to deselect and press Ctrl + Home


[image: image287]
	ClipArt and Pictures

	


	Microsoft Office ships with a lot of pictures that you can use to enhance your worksheet. You can also include almost any kind of picture from almost any format.

The ClipArt Gallery that installs with Microsoft Excel organizes its files in various categories. To access them, on the main menu, you can click Insert -> Picture > ClipArt. Select a category by clicking its button, review the available picture, once you like one, click it, and click Insert from the menu that comes up. You can also access additional pictures from Microsoft web site.
Using any commercial graphics software, you can also create your own graphics. You can as well use company or personal pictures. Once you have one of these pictures or images in a suitable electronic format, on the main menu, click Insert -> Picture -> From File… Locate the folder where the picture is located, and select it.

Microsoft Excel also allows you to completely change a worksheet’s background with a picture of your choice.


	[image: image288]Practical Learning: Including Microsoft Office ClipArt

	


	1. On the main menu, click Insert -> Picture -> ClipArt…

2. From the Insert ClipArt dialog, click Animals. Click the Lion (1st column, 1st row) and click Insert Clip

3. Close the ClipArt dialog box

4. Using its lower right handle, resize the picture to occupy the Pale Blue section from the left corner of cell B6 to the lower right corner of cell B6

5. On the main menu, click Format -> Sheet -> Background…

6. From your Exercises folder, click roshbg1 and click OK.

7. On the main menu, click Tools -> Options…

8. Make sure you are in the View property page. In the Window section, uncheck the Gridlines check box. Click OK

9. Save your workbook
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	Operators and Operands 

	


  

	Types of Values


	

	  

Introduction

An expression is a combination of values and symbols used to produce a new value. To do this, there are different types of values involved in an expression. They are:

A string is an empty space, a character, a word, or group of words considered as an entity. Any combination of letters or words you can think is primarily a string.

A Boolean value is one that can be expressed in only one of two values. In Microsoft Access, a Boolean value is expressed as either TRUE or as FALSE. A FALSE value also has the value of 0. In this case, any other numeric value is considered TRUE. Boolean values are mostly used in comparisons.

An integer is a natural number that displays without a decimal place. Examples of integers are 18, 16763, and 1450. If the number is very large, it can be considered as a Long integer.

A byte is a small integer that ranges from 0 to 255.

A double, also called double precision, value is a number that can display a decimal portion, using the character set as the decimal separator in Control Panel. For US English, that character would be the period. The expression “double-precision” means that this number provides a high level of precision. If you are dealing with a decimal number but precision is not important, then the number can be represented as a Single. Valid decimal numbers are 12.55, 3.14159 or 9.80336

A date is a numeric value that counts the number of days that have elapsed from a certain point of reference. How a date displays in a field is based on some conventions set by Microsoft Excel, Microsoft Windows, or you. There are also rules you must respect. Examples of dates are 28/06/1998, 10-8-82, January 10, 1865

A time is a numeric value that counts the number of seconds that have elapsed since midnight of a certain day. The time also displays following some conventions set in Control Panel, by Microsoft Excel, or the person who created the spreadsheet. Examples of time values are 10:42 AM and 18:06

The currency is a numeric value used to represent money. In some cases, you can use a double-precision value in place of the currency but because Microsoft Excel is equipped for accounting, you can safely take advantage of the currency type. When using currency rightly, its number presents the character specified in Control Panel. For US English, such a character is $.

Constants

A constant is a value that does not change. The constants you will be using in your expressions have already been created and are built-in Microsoft Excel. Normally, Visual Basic for Applications (VBA), the version of Microsoft Visual Basic that ships with Microsoft Excel also provides many constants. Just in case you are aware of them, you will not be able to use those constants, as Microsoft Excel does not inherently “understand” them. For this reason, we will mention here only the constants you can use when building regular expressions. 

The algebraic numbers you have been using all the time are constants because they never change. Examples of constant numbers are 12, 0, 1505, or 88146. Therefore, any number you can think of is a constant. Every letter of the alphabet is a constant and is always the same. Examples of constant letters are d, n, c. Some characters on your keyboard represent symbols that are neither letters nor digits. These are constants too. Examples are &, |, @, or ! 

In Boolean algebra, something is considered True when it holds a value. The value is also considered as 1 or Yes. By contrast, any other value is considered False, 0, or No. 

When a field holds a value, the value would be considered using the comparison operators we will learn.
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	Operands and Operators

	


	The values we have used so far were provided in cells of a spreadsheet. In some cases, you will need to display a value that is a combination of other values. For example, you may need to combine a first name to a last name to create a full name. In another case, to calculate an employee’s weekly salary, you may need to use the value of a salary and multiply it with a number of hours worked in a week. Most, if not all, of these expressions use what we call operators and operand.

An operation is a technique of using a value or the contents of a cell, or to combine two or more values or contents of cells to either modify an existing value or to produce a new value. Based on this, to perform an operation, you need at least one value or the contents of one cell and one symbol. A value involved in an operation is called an operand. A symbol involved in an operation is called an operator. .


	Regular Operators

	


  

	The Assignment Operator =

	


	In order to display a value in a cell, it must be preceded with the assignment operator, which is “=”. The syntax you would use is:

=ValueOrExpression

The operand on the right side of the assignment operator is referred to as the right value or Rvalue. It can be a known value or a reference to another cell.

There are two main ways we will use the assignment operator:

· Imagine you already have a cell such as B12 and you want to display its value in another cell such as A4. In A4, you can type =B12 and press Enter. The contents of B12 would be provided to, and displayed in, A4

· In some other operations and functions we will learn, you can use the = operator inside of the expression or function to perform another, intermediary operation, such as a comparison


	 Unary Operators

	


	A unary operator is one that uses only one operand. An operator is referred to as binary if it operates on two operands.

The Positive Unary Operator +
Algebra uses a type of ruler to classify numbers. This fictitious ruler has a middle position of zero. The numbers on the left side of the 0 are considered negative while the numbers on the right side of the 0 constant are considered positive: 
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	A value on the right side of 0 is considered positive. To express that a number is positive, you can write a + sign to its left. Examples are +4, +228, and +90335. In this case the + symbol is called a unary operator because it acts on only one operand. The positive unary operator, when used, must be positioned to the left side of its operand.

As a mathematical convention, when a value is positive, you don’t need to express it with the + operator. Just writing the number without any symbol signifies that the number is positive. Therefore, the numbers +4, +228, and +90335 can be, and are better, expressed as 4, 228, or 90335. Because the value does not display a sign, it is referred as unsigned.

The Negative Unary Operator -
In order to express any number on the left side of 0, it must be appended with a sign, namely the - symbol. Examples are -12, -448, and -32706. A value accompanied by - is referred to as negative. The - sign must be typed on the left side of the number it is used to negate.

Remember that if a number doesn’t have a sign, it is considered positive. Therefore, whenever a number is negative, it must have a - sign. In the same way, if you want to change a value from positive to negative, you can just add a - sign to its left. In the same way, if you want to negate the value of a cell, an expression, or a function, you can type the – operator on its left. 


	 The Double Quotes: ""

	


	Double-quotes are used to enclose a string. As we reviewed earlier, a string can be an empty space, one character, or a group of characters. Such a string must be considered “as is”. Therefore, to include a string in an expression, put it in double-quotes. Examples are “ “, "@", "Hermano", or "Rancho Cordova ".

To display a string in a cell, precede it with double-quotes. For example, to display Rancho Cordova in cell B4, you would click B4, type ="Rancho Cordova" and press Enter. 


	The String Concatenator: &

	


	The & operator is used to append two strings, the contents of two cells, or expressions. This is considered as concatenating them. For example, it could allow you to concatenate a first name and a last name, producing a full name. The general syntax of the concatenation operator is expressed as:

Value1 & Value2

To display a concatenated expression, use the assignment operator on the left of the string. For example, imagine you want to concatenate Juan to Marcus and display the resulting string in cell C5, in C5, you would type =”Juan” & “Markus” and press Enter. The result would be JuanMarkus.

To concatenate more than two expressions, you can use as many & operators between any two expressions as necessary. For example, to add an empty space in the above string, in cell C5, you would type =”Juan” & “ “ & “Markus”

In the same way, you can concatenate the contents of various cells.


	The Addition: +

	


	The addition is used to add one value or expression to another. It is performed using the + symbol and its syntax is:

Value1 + Value2

The addition allows you to add two numbers such as 12 + 548 or 5004.25 + 7.63

After performing the addition, you get a result. You can display such a result in a cell or use it as an intermediary variable in an expression. For example, to add 242.48 to 95.05 and display the result in cell C6, in C6, you would type =242.48 + 95.05 and press Enter.


	[image: image297]Practical Learning: Using the Addition

	


	1. Open the Red Oak High School workbook you started in Lesson7 and click Sheet2

2. In cell E11, type =E3+E4+E5+E6+E7+E8+E9+E19 press Enter

3. Click cell F11 and type =

4. Click cell F3 and type +

5. Click cell F4 and type +

6. Click cell F5 and type +

7. Click cell F6 and type +

8. Click cell F7 and type +

9. Click cell F8 and type +

10. Click cell F9 and type +

11. Click cell F10 and press Enter

12. Save the workbook


   

	The Subtraction: -

	


	The subtraction is performed by retrieving one value from another value. This is done using the - symbol. The syntax used is:

Value1 - Value2

The value of Value1 is subtracted from the value of Value2. After performing the operation, a new value results. This result can be used in any way you want. For example, you can display it in a cell using the assignment operator as follows:

= Value1 - Value2


	The Multiplication: *

	


	The multiplication allows adding one value to itself a certain number of times, set by the second value. The multiplication is performed with the * sign which is typed with Shift + 8. Here is an example:

Value1 * Value2

During the operation, Value1 is repeatedly added to itself, Value2 times. The result can be assigned to another value or displayed in a control as follows:

= Value1 * Value2


	The Division: /

	


	The division is used to get the fraction of one number in terms of another. For example, to divide a Value1 if Value2 pieces, you would use a syntax as:

Value1 / Value2

After performing the operation, you get a new result you can use as you see fit. You can display in a cell or involve it in an expression.


	The Exponentiation: ^

	


	Exponentiation is the ability to raise a number to the power of another number. This operation is performed using the ^ operator (Shift + 6). It uses the following mathematical formula:

yx
The operation is performed as y^x and means the same thing. Either or both y and x can be values or expressions, but they must carry valid values that can be evaluated.

When the operation is performed, the value of y is raised to the power of x. You can display the result of such an operation in a cell using the assignment operator as follows:

=y^x

You can also use the operation in an expression.


	The Parentheses Operators: ()

	


	Parentheses are used to create sections in an expression. This regularly occurs when more than one operator is used in an operation. Consider the following expression typed in cell F2 as =8 + 3 * 5. The result of this operation depends on whether you want to add 8 to 3 then multiply the result by 5 or you want to multiply 3 by 5 and then add the result to 8.

Parentheses allow you to specify which operation should be performed first in a multi-operator operation. In our example, if you want to add 8 to 3 first and use the result to multiply it by 5, in the cell, you would write =(8 + 3) * 5. This would produce 55. On the other hand, if you want to multiply 3 by 5 first then add the result to 8, you would write 8 + (3 * 5). This would produce 23.

As you can see, results are different when parentheses are used on an operation that involves various operators. This concept is based on a theory called operator precedence. This theory manages which operation would execute before which one; but parentheses allow you to control the sequence of these operations.


	Worksheets and Expressions

	


	To create a pseudo-database, you can connect worksheets that would exchange information. This is a valuable use of lists as one worksheet can be used to store particular information and make it available to other worksheets. In Lesson3, we already saw briefly how worksheets can be linked. We didn't expand on it because we had not been introduced to expressions or functions yet. Fortunately, almost any expression or function you use in the cells inside one worksheet can also be used in linked worksheets.

	


	Introduction to Functions

	


  

	The Structure of a Function


	

	  

Introduction

A function is a small assignment that is performed to produce a result that can be reliably used without caring as to how the function works or how it was created. It is like when you pick up a TV remote control and press a button to change the channel. You don’t care how the remote control works and you don’t spend any time finding out why the channel changed. As in real world where we use various functions on cars, radio stations, food eating, etc, in the computer world, various functions are made available so you can simply use them to do your job. As a spreadsheet application, Microsoft Excel is equipped with various functions that can solve different types of calculations.

In order to use a function more effectively, you should first know whether it is available and what you need to do to make it work. A function involves four main issues:

· The name of the function: Obviously, in order to use a function, you must know its name.
Although the functions are not case-sensitive, it is a good idea to always write them in uppercase.

· The purpose of the function: what the function used for. Different functions are meant for different purposes. For example, when you press the power button on a TV remote control, the TV gets turned ON or OFF depending on whether it was already ON or OFF. Therefore, the purpose of the power button (that is, its function) is to turn the TV ON or OFF and vice versa

· What the function needs in order to carry its assignment: this need is called argument (or arguments). A function can use more than one argument. For example, you use one key to turn on the car. Another function may need more than one argument. The arguments can be the same kind. For example, some remote controls use two similar batteries. The arguments may also be different kind.

On a function that takes one argument, the argument may be required. In this case, you must provide it. If you don't, the function will not work (the result would be an error). In other circumstances, an argument may not be required. In this case, if you don’t provide the argument, the function would use its own value, called a default argument.

If a function takes more than one argument, all arguments may be required. In this case, if you fail to provide all of them, the function would not work. Another function that takes more than one argument may not require all of them. There are even cases when a function takes many arguments but none of them is required. When an argument is not required, you don’t have to supply it. If you don’t, then the function would use a default value for that particular function.

The person who creates a function also decides on the number of its arguments, if the argument(s) is/are required and, if the function takes more than one argument, which ones are required, whether all of them are required or none of them is required.

· The result of the function: after using a function, you need its result so you can use it for its intended purpose. Various functions produce various results but each function is intended for a specific purpose. For example, one function may take two words as the first and the last name. The function may then produce a full name. Another function may take one number, multiply it by its own number, and produce a new number. Yet another function may take a sentence and a number then produce another value.

Using a Function

To us a function in your spreadsheet, you can display its result in a cell. Because a cell is just a box ready to display anything, it is your job to get the result ready to display. Fortunately, and as we have seen in the past, the cell is equipped to interpret values that are provided to it.

If you are displaying the result of a function in a cell, the use and implementation of a function always starts with an equal symbol "=" followed by the name of the function. If you know the name of a function and its arguments, to use it, you can type = in a cell, followed by the name of the function, followed by an opening parenthesis. Microsoft Excel will know that you are trying to use a function and will offer to help.

The functions that ship with Microsoft Excel can be divided in various categories. 
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	Fundamental Functions

	


  

	Introduction

	


	Before getting into functions, let's experiment with Microsoft Excel's use and recognition of mathematical operations.

Microsoft Excel is aware of such algebra operations as the addition (+), the subtraction (-), the multiplication (*), and the division (/). These operations can be applied to numbers typed in a cell when performing the operation, they can be gotten from another cell. 


	 The AutoSum

	


	The SUM function is the most basic and one of the most popular functions used in Microsoft Excel. It is used to get the addition of various numbers or the contents of various cells. The result can be displayed in another cell or used in an expression.

The Standard toolbar is equipped with a button called the AutoSum. There are two most primary ways of using the AutoSum. You can click an empty contiguous cell, and then click the AutoSum button [image: image305]. Before performing the SUM function, the computer will ask whether it found the right cells that you want to get the sum of. If the computer found the right cells, you can press Enter; otherwise use your mouse or your keyboard to select the cells you want to consider. You can also select the cells involved in a sum plus an empty cell that will be used to display the result, and then click the AUTOSUM button.


	[image: image306]Practical Learning: Using AutoSum

	


	1. Open the Red Oak High School1 workbook you created in Lesson7
2. In Sheet1, press Ctrl + A and Ctrl + C

3. Click Sheet3. Press Ctrl + Home and press Enter

4. Expand it with the following new values in columns H, I, and J
 
[image: image307]
5. In cell B11, type TOTAL
6. Click cell C11 to give it focus

7. On the Standard toolbar, click AutoSum [image: image308]. Notice that Microsoft Excel selects the cells on the upper region of the selected cells; their blinking border is the application's way of asking whether these are the cells you want to get the sum of
  

[image: image309]
8. Press Enter

9. Select cells D3:D10

10. On the Standard toolbar, click AutoSum [image: image310]. Notice that Microsoft Excel displays the sum result directly. This is because you had selected the cells involved in the sum plus an empty adjacent cell that will display the result 

11. In cell G11, type =SUM( 

12. Select cells G3:G10 and press Enter 

13. In cell H11, type =SUM( 

14. Click cell H10 and type , 

15. Click cell H3 and type , 

16. Click cell H8 and type , 

17. Click cell H5 and type , 

18. Click cell H9 and type , 

19. Click cell H4 and type , 

20. Click cell H7 and type , 

21. Click cell H6 and press Enter. Notice that you don't have to follow an order of cells, just tell Microsoft Excel which cells are involved in the sum 

22. Click cell I11 to give it focus 

23. On the Standard toolbar, click the Paste Function button [image: image311]
24. From the Paste Function dialog box, in the Function Category list box, select Math & Trig 

25. In the Function Name list box, click SUM
  

[image: image312]
26. Click OK. 
Notice a new dialog, SUM, on the screen 

27. Position your mouse on a gray area that is not a button, then click, hold your mouse down and move it to a different area until you can see cell I13 

28. Notice that the Number 1 box already has the range of cells I3:I10
  

[image: image313]
29. Click OK 

30. Right-click cell I11 and click Copy 

31. Right-click cell J11 and click Paste. Notice that the pasted result is not the content of cell I11, only the formula has been copied but only conform to column G 

32. Click cell J11. Position your mouse on its Fill Handle (the lower right point of the selected cell). Click and drag its Fill Handle to cell K11
Notice that once again it is the formula that was copied to the subsequent cell 

33. Save the workbook
  


	AutoCalculate

	


	On the Status Bar, the AutoCalculate pane allows you to get a quick result of the most used functions in Microsoft Excel. 


	[image: image314]Practical Learning: Using AutoCalculate

	


	1. Select cells D5:D12 and observe the AutoCalculate section of the Status Bar

2. Right-click the AutoCalculate section (or anywhere on the Status Bar) and click None. Notice that the AutoCalculate section displays nothing

3. Right-click the AutoCalculate section again and click Sum
  

[image: image315]
4. Now the AutoCalculate section displays the sum of the selected cells.


	The Absolute Value

	


	The decimal numeric system counts from minus infinity (-∞) to infinity (+∞). This means that a  number can be usually negative or positive, depending on its position from 0, which is considered as neutral. In some operations, the number considered will need to be only positive even if it is provided in a negative format.

The absolute value of a number x is x if the number is (already) positive. If the number is negative, then its absolute value is its positive equivalent. For example, the absolute value of 12 is 12, while the absolute value of –12 is 12.

To get the absolute value of a number, you can use one of the ABS() function. Its syntax is:

ABS(number)

  


	The Ceiling of a Number 

	


	Consider a floating number such as 12.155. As you can see, this number is between integer 12 and integer 13

[image: image316]
On the other hand, consider a number such as –24.06. As this number is negative, it is between –24 and –25, with –24 being greater.

In arithmetic, the ceiling of a number is the closest integer that is greater or higher than the number considered. In the first case, the ceiling of 12.155 is 13 because 13 is the closest number greater than or equal to 12.155. The ceiling of –24.06 is –24.

To find the ceiling of a number, you can use the CEILING function used to obtain the ceiling of a number uses the following syntax:

CEILING(number, significance)

The function takes two arguments. The number argument is the one that will be considered. The significance argument is the nearest multiple significance


	The Floor of a Number

	


	Consider two floating numbers such as 128.44 and -36.72. The number 128.44 is between 128 and 129 with 128 being the lower. The number –36.72 is between –37 and –36 with –37 being the lower. The lowest but closest integer value of a number is referred to as its floor. For example, the floor of 128.44 is 128. The floor of –36.72 is –37.

To get the floor of a number, you can use the FLOOR function. Its syntax is:

FLOOR(number, significance)

The FLOOR() function takes two arguments. The first argument argument is the number to be considered. The second argument is the nearest multiple of significance.
 


	The Power of a Number

	


	We saw in Lesson8 that, to raise a number to another, you could use the ^ operator. Microsoft Excel provides a function to perform the same operation.

The POWER() function is used to calculate the value of one number or expression raised to the power of another number. It uses the formula xy. The syntax of the POWER function is:

POWER(number, power)

This function takes two required arguments. The first argument, number, is used as the base number to be evaluated. The second argument, power, also called the exponent, will raise number to this value.


	The Exponential 

	


	Microsoft Excel provides the EXP function used to calculate the exponential value of a number. Its syntax is:

EXP(number)

The argument, number, a double-precision value, represents the number to be evaluated. If the value of number is less than -708.395996093 (approximately), the result is reset to 0 and qualifies as underflow. If the value of the argument x is greater than 709.78222656 (approximately), the result is infinity and qualified as overflow.

 


	The Log10

	


	The LOG10 function calculates the base 10 logarithm of a number. The syntax of this function is:

LOG10(number)

The number to be evaluated is passed as the argument number. The function returns the logarithm on base 10 using the formula:

y = LOG10x which is equivalent to x = 10y 


	The Square Root

	


	There are two forms of calculating the square root of a (real positive) number. The SQRT function is used to calculate the square root of a double-precision number. Its syntax is:

SQRT(number)

This function takes one argument as a positive floating number. After the calculation, the function returns the square root of x:

= SQRT(E12)


	Other arithmetic functions include COMBIN, EVEN, EXP, FACT, INT, LN, LOG, LOG10, MOD, ODD, PI, RAND, ROMAN, ROUND, ROUNDDOWN, ROUNDUP, SIGN, SQRT, SUBTOTAL, SUMSQ, and TRUNC.

	


	Collections and Business Functions

	


  

	Series-Based Functions


	

	  

Introduction

A series or collection-based function is one that operates on a group of values. The values are stored in a collection called an array.  

The Average of a Series: 

The AVERAGE function calculates the average or mean value of a group of values. It can take the sum of the cells involved (you don't need to calculate the sum first), divide the result by the number of values involved, and produce the result.

We will use the AVERAGE function to get the average grade for each student's grade. 

[image: image318]Practical Learning: Using Using the Average Function

1. Open the Red Oak High School1 workbook you started in lesson 7

2. In cell B12, type Average
3. In cell C12, type =AVERAGE(
4. To get the average of the first student's grade, select cells C3:C12 and press Enter

5. Click cell C14 to give it focus

6. On Standard toolbar, click the Paste Function button

7. In the Function Category, click Most Recently Used. In the Function Name, click AVERAGE; if you don't see AVERAGE, then in the Function Category, click Statistical, and in the Function Name, click AVERAGE. Click OK

8. Move the AVERAGE dialog box to the right to make sure you can see cell C14

9. Since the AVERAGE dialog is a modeless dialog box, which means you can have access to the main window behind it while the dialog box is opened, select cells C5:C12. Click OK. 
Right-click cell C14 and click Copy

10. Select cells D14:J14 and press Enter. Notice that since the copying was done on a cell that has a function's result, only the formula was copied. Also notice the errors on cells I14 and J14; don't worry about those errors, they will find a solution in a few seconds. 

The Minimum in a Series 

The MIN function is used to find the lowest of a group of group of values.

[image: image319]Practical Learning: Finding the Minimum Value of a Series

1. In cell K2, type Minimum and press Tab

2. Click cell K3 to give it focus

3. Click the Edit Formula button of the Formula Bar. Now the Name Box over the A column displays the most recently used function which is AVERAGE

4. Click the arrow of the Name Box to display a list of the most recently used functions. 
If you see MIN, click it. If you don't see MIN in the list, click More Functions... from the list. That will call the Paste Function dialog box that we are already familiar with. In the Function Category, click Statistical. In the Function Name, click MIN. Click OK

5. Move the MIN dialog box to the lower section of the monitor to make sure you can see row 5

6. Select cells C3:J3

7. Click OK 
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	The Maximum in a Series 

	


	The MAX function is used to get highest of a series of value. 


	[image: image326]Practical Learning: Finding the Maximum Value of a Series

	


	1. Click cell L2 and type Maximum

2. Click cell L3 and type =MAX(
3. Select cells C3:J3 and press Enter

4. Select cells K3 and L3

5. Drag their Fill Handle (the big point in the lower right corner of L3) down to cell K12:L12 


  

	Counting the Number of Numeric Values in a Series 

	


	Imagine you want to perform some type of counting in a series of cells, Microsoft Excel provides various functions used to count items in a collection. Everything depends on what and/or how you want to count.

The COUNT function counts the number of cells that contain numbers in the range or group of cells involved in a collection.


	Counting the Number of Non-Empty Cells in a Series 

	


	While the COUNT function counts the numbers, the COUNTA function counts the number of non-empty cells (regardless of what is in those cells, as long as they contain something) in the cells involved.


	Business Functions

	


  

	Introduction 

	


	An asset is an object of value. It could be a person, a car, a piece of jewelry, a refrigerator. Anything that has a value is an asset. In the accounting world, an asset is a piece of/or property whose life span can be projected, estimated, or evaluated. As days, months or years go by, the value of such an asset degrade.

When an item is acquired for the first time as “brand new”, the value of the asset is referred to as its Cost. The declining value of an asset is referred to as its Depreciation. At one time, the item will completely lose its worth or productive value. Nevertheless, the value that an asset has after it has lost all of its value is referred to its Salvage Value. At any time, between the purchase value and the salvage value, accountants estimate the value of an item based on various factors including its original value, its lifetime, its usefulness (how the item is being used), etc.


	The Double Declining Balance 

	


	The Double Declining Balance is a method used to calculate the depreciating value of an asset.  To get it, you can use the DDB function whose syntax is:

DDB(cost, salvage, life, period, factor)

The first argument, cost, represents the initial value of the item and it is required. The salvage argument is the estimated value of the asset when it will have lost all its productive value. This argument also is required. The cost and the salvage values must be given in their monetary values. The value of life is the length of the lifetime of the item; this could be the number of months for a car or the number of years for a house, for example. The period is a factor for which the depreciation is calculated. It must be in the same unit as the life argument. For the Double Declining Balance, this period argument is usually 2.
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	1. Start a new workbook and fill up Sheet1 as follows:
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2. Save it as Depreciation
3. Double-click Sheet1 to put its label into edit mode. Type Double-Declining-Balance and press Enter

4. Click cell C8 and, on the main menu, click Insert -> Function...

5. In the Paste Function dialog box, in the Function Category list, click Financial. In the Function Name list, double-click DDB and move the DDB window so you can see the values on the worksheet

6. Click the box to the right of Cost and, on the worksheet, click cell C4

7. In the DDB window, click the box to the right of Salvage and, on the worksheet, click cell C5

8. In the DDB window, click the box to the right of Life and, on the worksheet, click cell C6

9. In the DDB window, click the box to the right of Period and, on the worksheet, click cell C7

10. In the DDB window, click the box to the right of Salvage and type 2
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11. Click OK


	The Straight Line Depreciation 

	


	Microsoft Excel provides another method used to calculate the depreciation of an item. This time, the depreciation is considered on one period of the life of the item. The function used is SLN and its syntax is:

SLN(cost, salvage, life);

The cost argument is the original amount paid for an item (refrigerator, mechanics toolbox, high-volume printer, etc). The salvage, also called the scrap value, is the value that the item will have (or is having) at the end of Life. The life argument represents the period during which the asset is (or was) useful; it is usually measured in years.
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	1. Click Sheet2 and fill it up as follows:
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2. Double-click Sheet2 to put its label into edit mode. Type Straigh-Line and press Enter

3. Click cell C8 and, on the main menu, click Insert -> Function...

4. In the Paste Function dialog box, in the Function Category list, click Financial. In the Function Name list, double-click SLN and move the SLN window so you can see the values on the worksheet

5. Click the box to the right of Cost and, on the worksheet, click cell C4

6. In the SLN window, click the box to the right of Salvage and, on the worksheet, click cell C5

7. In the SLN window, click the box to the right of Life and, on the worksheet, click cell C6

8. In the SLN window, click OK 

9. Click OK


 

	The Sum of the Years' Digits 

	


	The Sum-Of-The-Years’-Digits provides another method for calculating the depreciation of an item. Imagine that a restaurant bought a commercial refrigerator (“cold chamber”) for $18,000 and wants to estimate its depreciation after 5 years. Each year is assigned a number, also called a tag, using a consecutive count. This means that the first year is appended 1, the second is 2, etc. This way, the depreciation is not uniformly applied to all years.

Year=>1,2,3,4,and5.

The total count is made for these tags. For our refrigerator example, this would be

Sum=1+2+3+4+5=15

Each year is divided by this Sum, also called the sum of years, used as the common denominator: 
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This is equivalent to 1. As you can see, the first year would have the lowest divident (1/15 ≈ 0.0067) and the last year would have the highest (5/15 ≈ 0.33).

To calculate the depreciation for each year, the fractions (1/15 + 2/15 + 3/15 + 4/15 + 5/15) are reversed so that the depreciation of the first year is calculated based on the last fraction (the last year divided by the common denominator). Then the new fraction for each year is multiplied by the original price of the asset. This would produce (this table assumes that the refrigerator will have a value of $0.00 after 5 years): 

Year

Fraction

*

Amount

=

Depreciation

1

5/15

*

$18,000.00

=

$6,000.00

2

4/15

*

$18,000.00

=

$4,800.00

3

3/15

*

$18,000.00

=

$3,600.00

4

2/15

*

$18,000.00

=

$2,400.00

5

1/15

*

$18,000.00

=

$1,200.00

Total Depreciation

=

$18,000.00

Overall, Microsoft Office uses the following formula to calculate an item depreciation using the Sum-Of-The-Years'-Digits: 
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The function used to calculate the depreciation of an asset using the sum of the years' digits is called SYD and its syntax is:

SYD(cost, salvage, life, period)

The cost argument is the original value of the item; in our example, this would be $18,000. The salvage parameter is the value the asset would have (or has) at the end of its useful life. The life is the number of years the asset would have a useful life (because assets are usually evaluated in terms of years instead of months). The period parameter is the particular period or rank of a Life portion. For example, if the life of the depreciation is set to 5 (years), the period could be any number between 1 and 5. If set to 1, the depreciation would be calculated for the first year. If the Period is set to 4, the depreciation would calculated for the 4th year. You can also set the period to a value higher than life. For example, if life is set to 5 but you pass 8 for the period, the depreciation would be calculated for the 8th year. If the asset is worthless in the 8th year, the depreciation would be 0.
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	1. Click Sheet3 and fill it up as follows:
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2. Double-click Sheet3 to put its label into edit mode. Type Sum-Of-Years and press Enter

3. Click cell C8 and, on the main menu, click Insert -> Function...

4. In the Paste Function dialog box, in the Function Category list, click Financial. In the Function Name list, double-click SYD and move the SYD window so you can see the values on the worksheet

5. Click the box to the right of Cost and, on the worksheet, click cell C4

6. In the SYD window, click the box to the right of Salvage and, on the worksheet, click cell C5

7. In the SYD window, click the box to the right of Life and, on the worksheet, click cell C6

8. In the SYD window, click the box to the right of Life and, on the worksheet, click cell C7
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9. Click OK

10. Notice that in our evaluation, we decided that the item would have a $0.00 value at the end of its life. Since this is still a big investment, it is very likely to still be very operational after 5 years. To experiment with different factors, let's assume that the item will have a value of $3500 after 5 years.
On the worksheet, click cell C5. Type 3500 and press Enter

11. Now, imagine that we think that the item will have a value of $0.00 after 5 years but we want to know how much it will have depreciated the 3rd year.
On the worksheet, click cell C5 and type 0

12. Click cell C7. Type 3 and press Enter
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13. Compare with the value we got in our table above

14. Save the workbook

	


	Financial Functions 

	


  

	Finance Functions


	

	  

Introduction

Microsoft Excel provides a series of functions destined to perform various types of financially related operations. These functions use common factors depending on the value that is being calculated. Many of these functions deal with investments or loan financing.

The Present Value is the current value of an investment or a loan. For a savings account, a customer could pledge to make a set amount of deposit on a bank account every month. The initial value that the customer deposits or has in the account is the Present Value. The sign of the variable, when passed to a function, depends on the position of the customer. If the customer is making deposits, this value must be negative. If the customer is receiving money (lottery installment, family inheritance, etc), this value should be positive.

The Future Value is the value the loan or investment will have when the loan is paid off or when the investment is over. For a car loan, a musical instrument loan, a financed refrigerator, a boat, etc, this is usually 0 because the company that is lending the money will not take that item back (they didn't give it to the customer in the first place, they only lend him or her some money to buy the item). This means that at the end of the loan, the item (such as a car, boat, guitar, etc) belongs to the customer and it is most likely still worth something.

As described above and in reality, the Future Value is the amount the item would be worth at the end. In most, if not all, loans, it would be 0. On the other hand, if a customer is borrowing money to buy something like a car, a boat, a piano, etc, the salesperson would ask if the customer wants to put a "down payment", which is an advance of money. Then, the salesperson or loan officer can either use that down payment as the Future Value parameter or simply subtract it from the Present Value and then apply the calculation to the difference. Therefore, you can apply some type of down payment to your functions as the Future Value.

The Number Of Periods is the number of payments that make up a full cycle of a loan or an investment.

The Interest Rate is a fixed percent value applied during the life of the loan or the investment. The rate does not change during the length of the Periods.

It is very important to understand how these two arguments are passed to a function. The period could be the number of months of a year, which is 12; but it could be another length. Suppose a customer is getting a car loan that would be financed in 5 years. This is equivalent to 5 * 12 = 60 months. In the same way, a cash loan can stretch from 0 to 18 months, a carpenter truck loan can have a life financing of 40 months, and a condominium can be financed for 15 years of 12 months plus an additional 8 months; this is equivalent to (15 * 12) + 8 = 188 months. Here is the tricky part, especially as far as Microsoft Excel deals with its finance functions. If you pass the number of Periods in terms of years, such as 5 for a car loan that stretches over 5 years, then you can pass the Rate as a percentage value, such as 8.75%. If you pass the number of Periods in terms of months, for example you can pass it as 44 for a car that is financed in 3 years and 8 months, then you must communicate this to the Rate argument by dividing the Rate by 12. In other words, a Rate of 8.75% would be passed as 8.75%/12. If the Rate was typed in a cell named B2 that displays 8.75%, you can pass it as B2/12.

For deposits made in a savings account, because their payments are made monthly, the rate is divided by the number of Periods of a year, which is 12. If an investment has an interest rate set at 14.50%, the Rate would be 14.50/12 = 1.208. Because the Rate is a percentage value, its actual value must be divided by 100 before passing it to the function. For a loan of 14.50% interest rate, this would be 14.50/12 = 1.208/100 = 0.012.

The Payment is the amount the customer will be paying. For a savings account where a customer has pledged to pay a certain amount in order to save a set (goal) amount, this would be the amount the customer would pay every month. If the customer is making payments (car loan, mortgage, deposits to a savings account, etc), this value must be negative. If the customer is receiving money (lottery installment or annuity, family inheritance, etc), this value must be positive.

The Payment Type specifies whether the payment is made at the beginning or the end of the period. For a monthly payment of an item financed like a car, a boat, a guitar, or a house this could be the end of every month.

 

The Future Value of an Investment

To calculate the future value of an investment, you can use the FV() function. The syntax of this function is: 

FV(Rate, Periods, Payment, PresentValue, PaymentType)

  

[image: image339]Practical Learning: Calculating the Future Value

1. Start a new workbook and fill up Sheet1 as follows:
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2. Save it as Business
3. Double-click Sheet1 to put its label into edit mode. Type Future Value and press Enter

4. Click cell C8 and, on the main menu, click Insert -> Function...

5. In the Paste Function dialog box, in the Function Category list, click Financial. In the Function Name list, double-click FV and move the FV window so you can see the values on the worksheet

6. Click the box to the right of Rate and, on the worksheet, click cell C5 and type /12
7. In the FV window, click the box to the right of Nper and, on the worksheet, click cell C7

8. In the FV window, click the box to the right of Pmt and type -

9. On the worksheet, click cell C6

10. In the FV window, click the box to the right of Pv and type -

11. On the worksheet, click cell C4

12. Since this is a loan, the payments are expected at the end of the month. Therefore, in the FV window, click the box to the right of Type and type 0
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13. Click OK

The Number of Periods of an Investment

To calculate the number of periods of an investment or a loan, you can use the NPER() function. Its syntax is:

NPER(Rate, Payment, PresentValue, FutureValue, PaymentType);

Here is an example:

[image: image342]
 

Investment or Loan Payment

The PMT() function is used to calculate the regular payment of loan or an investment. Its syntax is:

PMT(Rate, NPeriods, PresentValue, FutureValue, PaymentType)

In the following example, a customer is applying for a car loan. The cost of the car will be entered in cell C4. It will be financed at a rate entered in cell C6 for a period set in cell C7. The dealer estimates that the car will have a value of $0.00 when it is paid off. 
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	1. Double-click Sheet3 to put it in edit mode. Type Payments Amount and press Enter 

2. Complete the worksheet as follows
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3. Click cell C8 and type =PMT(
4. Click cell C6 and type /12, 

5. Click cell C7 and type ,-
6. Click cell C4 and type ,
7. Click cell C5

8. Type ,0) and, on the Formula Bar, click the Enter button [image: image351]
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9. Suppose that, during the evaluation, a customer decides that she doesn't need a brand new car anymore. Also, she thinks that a 5-year car loan is too long. Furthermore, she wants to make a $4500.00 down payment to reduce the monthly payments. On the other side of the desk, the salesperson who wants to make a juicy commission on this loan has decided to increase the interest rate.
Change the new values of the worksheet as follows and see the result
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10. Save the workbook
  


	The Amount Paid As Interest During a Period 

	


	When a customer is applying for a loan, an investment company must be very interested to know how much money it would collect as interest. This allows the company to know whether the loan is worth giving. Because the interest earned is related to the interest rate, a company can play with the rate (and also the length) of the loan to get a fair (?) amount. 

The IPMT() function is used to calculate the amount paid as interest on a loan during a period of the lifetime of a loan or an investment. It is important to understand what this function calculates. Suppose a customer is applying for a car loan and the salesperson decides (or agrees with the customer) that the loan will be spread over 5 years (5 years * 12 months each = 60 months). The salesperson then applies a certain interest rate. 

The IPMT() function can help you calculate the amount of interest that the lending institution would earn during a certain period. In essence, you can use it to know how much money the company would earn in the 3rd year, or in the 4th year, or in the 1st year. Based on this, this function has an argument called Period, which specifies the year you want to find out the interest earned in. 

The syntax of the IPMT() function is:

IPMT(Rate, Period, NPeriods, PresentValue, FutureValue, PaymentType)

The Rate argument is a fixed percent value applied during the life of the loan. 

The PresentValue is the current value of the loan or investment. It could be the marked value of the car, the current mortgage value of a house, or the cash amount that a bank is lending. 

The FutureValue is the value the loan or investment will have when the loan is paid off. 

The NPeriods is the number of periods that occur during the lifetime of the loan. For example, if a car is financed in 5 years, this value would be (5 years * 12 months each =) 60 months. When passing this argument, you must remember to pass the right amount. 

The Period argument represents the payment period. For example, it could be 3 to represent the 3rd year of a 5 year loan. In this case, the IPMT() function would calculate the interest earned in the 3rd year only. 

The PaymentType specifies whether the periodic (such as monthly) payment of the loan is made at the beginning (1) or at the end (1) of the period. 

The FutureValue and the PaymentType arguments are not required.
  


	[image: image354]Practical Learning: Calculating the Monthly Payments of a Loan

	


	1. To add a new worksheet, on the main menu, click Insert -> Worksheet 

2. Double-click the new Sheet1 tab to put it in edit mode. Type Periodic Interest Earned and press Enter 

3. Move the new worksheet to be the most right 

4. Complete the worksheet as follows
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5. Click cell C9 and type =IPMT(
6. Click cell C5 and type /12, 

7. Click cell C6 and type ,
8. Click cell C7 and type ,-
9. Click cell C4 and type ,
10. Click cell C8 and type ,
11. Type ,0) and, on the Formula Bar, click the Enter button [image: image356]
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12. Save the workbook
  


	The Amount Paid as Principal

	


	While the IPMT() function calculates the amount paid as interest for a period of a loan or an investment, the PPMT() function calculates the actual amount that applies to the balance of the loan. This is referred to as the principal. Its syntax is:

PPMT(Rate, Period, NPeriods, PresentValue, FutureValue, PaymentType)

The arguments are the same as described in the previous sections.
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	1. Change the Periodic Interest Earned worksheet as follows
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2. Click cell C10 and type =PPMT(
3. Click cell C5 and type /12, 

4. Click cell C6 and type ,
5. Click cell C7 and type ,-
6. Click cell C4 and type ,
7. Click cell C8 and type ,
8. Type ,0) and, on the Formula Bar, click the Enter button [image: image360]
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9. Save the workbook 


	The Present Value of a Loan or an Investment 

	


	The PV() function calculates the total amount that a future investment is worth currently. Its syntax is:

PV(Rate, NPeriods, Payment, FutureValue, PaymentType)

The arguments are the same as described earlier. 


	The Interest Rate 

	


	Suppose a customer comes to a car dealer and wants to buy a car. The salesperson would first present the available cars to the customer so the customer can decide what car he likes. After this process and during the evaluation, the sales person may tell the customer that the monthly payments would be $384.48. The customer may then say, "Wooooh, I can't afford that, man". Then the salesperson would ask, "What type of monthly payment suits you". From now on, both would continue the discussion. Since the salesperson still wants to make some money but without losing the customer because of a high monthly payment, the salesperson would need to find a reasonable rate that can accommodate an affordable monthly payment for the customer. 

The RATE() function is used to calculate the interest applied on a loan or an investment. Its syntax is:

RATE(NPeriods, Payment, PresentValue, FutureValue, PaymentType, Guess)

All of the arguments are the same as described for the other functions, except for the Guess. This argument allows you to give some type of guess for a rate. This argument is not required. If you omit it, its value is assumed to be 10. 
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	1. To add a new worksheet, on the main menu, click Insert -> Worksheet 

2. Double-click the new Sheet1 tab to put it in edit mode. Type Interest Rate and press Enter 

3. Move the new worksheet to be the most right 

4. Change the Interest Rate worksheet as follows
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5. Click cell C8 and type =-RATE(
6. Click cell C7 and type , 

7. Click cell C6 and type ,-
8. Click cell C4 and type ,
9. Click cell C5 and type ,0)*12 and, on the Formula Bar, click the Enter button [image: image364]
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10. To use the ABS() function, change the function in cell C14 to 
=ABS(RATE(C7,C6,-C4, C5, 0)*12) and press Enter 

11. Save the workbook 


 

	The Internal Rate of Return 

	


	The IRR() function is used to calculate an internal rate of return based on a series of investments. Its syntax is: 

IRR(Values, Guess)

The Values argument is a series (also called an array or a collection) of cash amounts that a customer has made on an investment. For example, a customer could make monthly deposits in a savings or credit union account. Another customer could be running a business and receiving different amounts of money as the business is flowing (or losing money). The cash flows don't have to be the same at different intervals but they should (or must) occur at regular intervals such as weekly (amount cut from a paycheck), bi-weekly (401k directly cut from paycheck), monthly (regular investment), or yearly (income). 

The Values argument must be passed as a collection of values, such as a range of selected cells, and not an amount. Otherwise you would receive an error. 

The Guess parameter is an estimate interest rate of return of the investment.
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	1. To add a new worksheet, on the main menu, click Insert -> Worksheet 

2. Double-click the new Sheet1 tab to put it in edit mode. Type Internal Rate of Return and press Enter 

3. Move the new worksheet to be the most right 

4. Change the worksheet as follows
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5. Click cell D12 and type =IRR(
6. Select cells D4:D10 and, on the Formula Bar, click the Enter button [image: image368]
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7. In cell D11, type 12 and click cell D12 

8. In the Formula Bar, change the function to =IRR(D4:D10, D11) and press Enter (you shouldn't need any significant difference unless you change the range of cells such as D4:D8) 

9. Save the workbook 


  

	The Net Present Value 

	


	The NPV() function uses a series of cash flows to calculate the present value of an investment. Its syntax is: 

NPV(Rate, Value1, Value2, ...)

The Rate parameter is the rate of discount during one period of the investment. 

As the NPV() function doesn't take a fixed number of arguments, you can add a series of values as Value1, Value2, etc. These are regularly made payments for each period involved. Because this function uses a series of payments, any payment made in the past should have a positive value (because it was made already). Any future payment should have a negative value (because it has not been made yet). 
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	1. To add a new worksheet, on the main menu, click Insert -> Worksheet 

2. Double-click the new Sheet1 tab to put it in edit mode. Type Net Present Value and press Enter 

3. Move the new worksheet to be the most right 

4. Change the worksheet as follows
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5. Click cell C14 and type =-NPV(
6. Click cell C13 and type , 

7. Select cells C4:C12 and, on the Formula Bar, click the Enter button [image: image372]
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8. To use the ABS() function, change the function in cell C14 to =ABS(NPV(C13,C4:C12)) and press Enter

9. Save the workbook 

	


	Date and Time Functions

	


  

	Dates


	

	  

Introduction



	A date is a number that represents the number of days that have elapsed from a set period in history. Microsoft Excel uses natural numbers to represent a date value as the number of days that have passed since 1/1/1900 on MS Windows (or since 1/2/1904 on Macintosh).


	Date Representation

	


To make a date easily recognizable, there is a formula you use, depending on the language. The first place you can check about representing dates is in Control Panel from the Regional Settings. In US English, this is represented as follows:

[image: image375]
Based on this, to represent a date (in US English), you use placeholders for numbers and a special symbol called the Date Separator. The default and most used date separator (in US English is the forward slash "/". Here is an example of representing a date: 8/5/2000.

Besides the numbers, you can use words to represent a date. The days of a week have names. There are three main ways to represent a day of a week. You can use a complete name as Sunday, Monday, Tuesday, Wednesday, Thursday, Friday, and Saturday. Each of these names also has an equivalent short name you can use instead. They are Sun, Mon, Tue, Wed, Thu, Fri, and Sat, respectively. A day of a week can also be represented by a natural number. By default, this would be 1 for Sunday, 2 for Monday, 3 for Tuesday, 4 for Wednesday, 5 for Thursday, 6 for Friday, and 7 for Saturday.

The months of a year have names. As done with weekdays, there are three main ways to represent a month. You can use a complete name as January, February, March, April, May, June, July, August, September, October, November, and December. Each of these names also has an equivalent short name you can use instead. They are Jan, Feb, Mar, Apr, May, Jun, Jul, Sep, Oct, Nov, and Dec respectively. A month can also be represented by a natural number. This would be 01 or 1 for January, 02 or 2 for February, 03 or 3 for March, 04 or 4 for April, 05 or 5 for May, 06 or 6 for June, 07 or 7 for July, 08 or 8 for August, 09 or 9 for September, 10 for October, 11 for November, or 12 for December.

When names to represent a date, you can use empty spaces to separate the components of a date. You can also use the comma and the empty space, where appropriate, to separate two sections of a date.

Microsoft Excel as a powerful mathematical tool, recognizes all the rules of date representation but because there can be so many ways of stating the same value, it completely allows you to indicate how you want your date values to be represented. Microsoft Excel also provides suggestive formats you can use.

	Dates-Related Functions

	


  

	Introduction

	


To support dates values and operations, Microsoft Excel provides many functions for various scenarios. With some functions, you will only use the value they provide (or return, as we studied about functions). With some other function, you will have to create a date by providing the necessary value(s) as argument(s). There are two categories of date values you will need to keep in mind when creating your expressions: deterministic and non-deterministic:

· A date value is referred to as deterministic when you know its value with certainty. For example, suppose that a company decides that nobody will work on 25 December of every year. This is a fixed day. If you involve it in an expression, you know with certainty when this date occurs, which is 25 December of the year blah blah blah (the year is not important for this example) 

· A date value is referred to as non-deterministic when you cannot know in advance when the exact date would occur but you know it will occur. For example, suppose that a company decides that, if December 20th occurs on Sunday, then the employees would receive their paychecks the Friday before, otherwise the employees would receive their paychecks the following Monday. In this case, when you write the expression, you cannot know with certainty when the date would occur (don't think that you should/can write an long expression that covers dates from 2000 to 2050; although you can, this is not professional and it is poor development). In this case, the date value you are involving in an expression is non-deterministic

For the sake of this lesson, we will use a data type called DateTime that represents a date (and/or a time) value. 

	Get Today's Date

	


The TODAY() function can be used to get the current date of the computer. Its syntax is:

DateTime TODAY()

This function takes no argument but it returns a value that represents the date of the computer in which it is called.

	Create a Date

	


To involve a fixed date in an expression, you can create it using the DATE() function. Its syntax is:

DateTime Date(int y, int m, int d)

This function takes three arguments and each must be an integer. The first argument is a year value. It can be passed as a 2-year or a 4-year digit. That is, the year can be as a number between 0 and 9999. If you pass the year with a single digit or two digits, like 2, 1900 would be added to it. For example, the number 2 would produce the year 1902. The number 08 would produce 1908 and not 2008. Therefore, you should make it a habit to pass the year with 4-digits. This is not an anomaly of Microsoft Excel. It was designed like that (if this appears like a problem to you, keep in mind that you are not the only one using MS Excel; someone else at the NIST or the Mossad is using it for something else, so 02 producing 1902 and not 2002 would suit him perfectly).

The second argument of this function represents the numeric month of the year. January is represented with 1 or 01, February with 2 or 02, etc.

The third argument of this function represents the numeric day of the month. 

Here is an example typed in a cell:

=Date(1988, 06, 05)

After calling this function and passing the required arguments, it produces a date value. When passing the value of the day, make sure you follow the rules of day values; otherwise, you may use an unpredictable result. If you provide an invalid date for either argument, Microsoft Excel would follow some algorithm to try to figure it out. For example, suppose you provide the following date:

=DATE(1975, 02, 35)

Fortunately, instead of displaying an error, Microsoft Excel would find out if the day number is valid. In this case it is not. Therefore, in this case, maximum number of days allowed for the month would be subtracted from the number you provided, the corresponding number of months would be added to the month value and the rest of days would be applied to the day argument: 
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	Date Conversion

	


Suppose a certain cell displays some text and that text might be the value of a date. Even if you believe that it is a date, it may be safe to convert such text first to a recognizable date value before using it. To convert text to a date value, you can use the DATEVALUE() function. Its syntax is:

DateTime DATEVALUE(Text)

This function takes one argument. The argument can be the content of a cell. When this function is called, it analyzes the text provided as argument. If the argument holds a valid date value, the function returns it. Here is an example: 

DATEVALUE("05/2/1977")

If the argument is not a valid date, you would receive an error (#VALUE). A remedy is to check if the text represents a date, then convert it, otherwise ignore it or do something else. 

	Returns the Parts of a Date

	


If a date has already been created but you want to retrieve only the year part, the month part, the day part, or all of the, Microsoft Excel provides three functions that can take care of this.

Year: The YEAR() function is used to retrieve the numeric year of a date value. Its syntax is

int YEAR(DateTime Value)

This function takes one argument. When called, it analyzes the argument. If the argument is a valid date, then the function returns its year, a value between 1900 and 9999. For example, YEAR(12/05/2002) returns 2002. If you pass the argument as a (Long) natural number or a decimal, Microsoft Excel would use some algorithm, first to create a valid date from the number, second to retrieve the year part. For example YEAR(37940.574) would produce 2003. If the argument is not a valid date and Microsoft Excel cannot convert it a valid date, then the function would produce an error (#VALUE).

Month: The MONTH() function is used to get the numeric value of the month of a date value. Its syntax is:

int MONTH(DateTime Value)

Day: The Day() function is used to produce the day part of a date value.  Its syntax is:

int DAY(DateTime Value)

	Times

	


  

	Introduction

	


A time is a decimal number that represents a fraction of a day. Unlike a date whose starting point can depend on various factors, a time is usually stated to start on a non-spatial point called midnight.

Like a date, a time is represented with a combination of numbers and special characters. Like a date, the character used depends on the language you are using. The character used can be checked in the Regional Settings of Control Panel in the Time property page:

[image: image378]
 To represent time, a day is divided into 24 non-spatial fractions and each of these fractions is called an hour. Each hour is divided into 60 fractions and each fraction is called a minute. The minutes are counted from 0 to 59. Each minute is divided into 60 fractions and each fraction is called a second. The seconds are counted from 0 to 59. Each second in divided into 1000 fractions and each fraction is called a millisecond. The milliseconds are counted from 0 to 999. The milliseconds are hardly used, only in extreme mathematically-oriented operations. To separate the sections of a time, you use a special character. In US English, that character is the colon. Therefore, 8 o'clock can be represented as 8:00

There are two ways to represent a time in a day. First, a day with light is divided into two sections. The first part is called morning. The other part is called afternoon. The period that divides them is called noon. One way you can represent a time, also called the military standard, counts the hours from 0 to 23. Using this technique, any time before 10 is represented with a leading 0. A time commonly called "8 o'clock" or "8 in the morning" is represented as 08:00. An equivalent time in the second part of the day is represented as 20:00. Using this military time, you don't actually don't indicate whether the time occurs in the morning or in the afternoon. The time stated provides complete information. The other technique of representing time consists of formally indicating in which part (also called a quadrant), the time period occurs. Using this technique, the first part of the day is represented with am, Am, or AM. This first part is counted from 0 to 11. Therefore, to indicate that the time occurs in the morning, after stating the time, you add an empty and type the two characters. An example is: 8:16 AM. The second part of the day is represented with the combination pm, Pm, PM. The hours of this part are also counted from 0 to 11. To indicate that the time occurs in the afternoon, after stating the time, you add an empty and type the two characters. An example is: 8:16 PM.

Microsoft Excel recognizes all the rules of time representation. Since there can be different scenarios to represent a value, it lets you customize how your time should appear.

	Date and Time Combination

	


  

	Introduction 

	


In some circumstances, you may want a date and a time value values to be considered as one entity. This is possible.

To get the current date and time with one call, you can use the NOW() function. This function returns a value in the formula M/D/YYYY HH:MM.

	




	


	Logical Operators and Functions

	


  

	Logical Operators


	

	  

Introduction




A logical operator is one used to perform a comparison between two values and produce a result of true or false (there is no middle result: something is not half true or half false or "Don't Know"; either it is true or it is false).

	Equality =

	


The equality operator is used to compare two values for similarity. The syntax of this operation is:

Value1 = Value2

If Value1 and Value2 hold the same value, then the comparison produces a TRUE result. If they hold different values, the comparison renders a FALSE value:

[image: image381]
Once the comparison has been performed, it processes a Boolean value you can use as you see fit. 

	Inequality <>

	


To find out if two values are different, you can use the inequality operator which is represented by <>. Its syntax is:

Value1 <> Value2

This comparison is performed between Value1 and Value2. If they hold different values, then the comparison produces a TRUE result. If they hold the same value, the comparison produces FALSE

[image: image382]
The equality (=) and the inequality (<>) operators are opposite each other. 

	Less Than <

	


The "Less Than" operator uses the following syntax:

Value1 < Value2

If Value1 holds a value that is lower than that of Value2, the comparison produces TRUE. If Value1 holds a value that is greater than or similar to that of Value2, the comparison renders FALSE 

[image: image383]
  

	Less Than Or Equal <= 

	


When comparing two values, you may want to know whether two fields hold the same value or if one is lower than the other. This comparison can be performed with the "Less Than Or Equal to" operator. It is represented by <=. Its syntax is: 

Value1 <= Value2

If both operands (Value1 and Value2) hold the same value, then the comparison produces a TRUE result. If Value1 holds a value that is lower than that of Value2, the comparison still produces a TRUE result. By contrast, if the value of Value1 is higher than that of Value2, the comparison renders a FALSE result 
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Note that the > and the <= operators are opposite each other. 

	Greater Than > 

	


The > operator is used to find out whether one value is "Greater Than" another. Its syntax is: 

Value1 > Value2

The operation is performed on the values of Value1 and Value2. If Value1 holds a value greater than that of Value2, then the comparison produces TRUE. Otherwise, the comparison produces FALSE. That is, if the value of Value2 is greater than or equal to that of Value1, then the comparison produces FALSE. 
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	Greater Than Or Equal >= 

	


If you have two values and want to find out whether they hold similar values or the first is greater than the second, you can use the >= operator whose syntax is: 

Value1 >= Value2

If both Value1 and Value2 hold the same value, then the comparison renders a TRUE result. Similarly, if the left operand, Value1, holds a value greater than that of the right operand, Value2, the comparison still produces TRUE. If the value of Value1 is less than the value of Value2, the comparison produces a FALSE result 
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Therefore, < and >= are opposite. 

	Logical Functions

	


  

	Introduction 

	


Because Microsoft Excel is not a programming environment, it doesn't use conditional statements seen in traditional languages such as C/C++, Pascal, C#, Visual Basic, etc. Instead, Microsoft Excel provides functions that can perform the same types of tests on cells' values and produce the same types of results.

A logical function is one that evaluates an expression and returns a Boolean result. For example, imagine you have a series of cells that represent employees last name. If you are interested to know what cell doesn't have a value (a last name), you can use a function. On the other hand, imagine you have a cell that is supposed to indicate whether an item must receive a discount, you can use a conditional function to check it.

Most, if not all, logical functions check a condition and render a result. The condition is also called a criterion. A criterion can be something like "Check if the cell contains Male", or "Check if the salary is less than $12.35". 

	IF 

	


To check whether a criterion is true or false before taking a subsequent action, you can use the IF() function. Its syntax is: 

IF(ConditionToTest, WhatToDoIfConditionIsTrue, WhatToDoIfConditionIsFalse)

When it is called, the IF() function checks the truthfulness or negativity of the ConditionToTest argument. If the result is true, then it will execute the first expression, WhatToDoIfConditionIsTrue in our syntax. If the result is false, it will consider the second option, the WhatToDoIfConditionIsFalse parameter in our syntax. 

	Nested IF 

	


The IF() function we have introduced above is used to check one condition and then take one or the other action. In some cases, you will need to check more than one condition. In other words, you may want to check a first condition. If that condition is false, you may want to yet check another condition. The pseudo-code used for such a scenario is:

	If Condition1 is True

	
	Execute Statement1

	Else If Condition2 is True

	
	Execute Statement2

	Else

	
	Execute ElseStatement


Consequently, you can check as many conditions as you need to. The truthfulness of each condition would lead to its own statement. If none of the conditions is true, then you can execute the last statement. To implement this scenario, you can include an IF() function inside of another. You can also include as many IF() functions inside of other IF() functions.

We are going to use the IF() function to find out whether a student passes the mark or fails the class, based on the overall average of the student's grades. We will set the mark at 12.50. If a student's average is above 12.50, then he goes to the next grade, otherwise, … 

	[image: image387]Practical Learning: Using the IF Functions

	


1. Open the Red Oak High School workbook from Lesson 11 

2. In cell B13, type Pass/Fail? 

3. In cell C13, type =IF( 

4. Click cell C12 and type >=12.50,"Pass","Fail") 

5. Press Enter 

6. Click cell C13 to give it focus 

7. Drag its Fill Handle to cell H15. 
You can also put an IF function inside of another, this is referred to as nesting 

8. In cell C14, type =IF(B14>16.5,"A",IF(B14>14.5,"B",IF(B14>12.5,"C",IF(B14>12,"D","F")))) and press Enter 

	Conditional Counting 

	


In some cases you will need to count the frequency of (the number of times that) a value repeat itself in a series of cells. For example, suppose you have a list of students recognized by their gender using a certain column. Provided the genders are, for example, Male or Female. You may be interested in knowing the number of boys. In this case you can count the number of occurrences of Male in the range of cells. 

The count the number of occurrences of a value in a series, you can use the COUNTIF() function. Its syntax is 

COUNTIF(Range, Criteria)

The functions include MDETERM, MINVERSE, MMULT, PRODUCT, SUMSQ, SUMX2MY2, SUMX2PY2, and SUMXMY2. 

	Text-Based Functions

	


  

	Concatenating Strings

	


The CONCATENATE() function is used to add two or more strings to create a new string. 

	Practical Learning: Controlling Worksheets Display

	


1. Open the Red Oak High School5 workbook 

2. Click the Student Registration worksheet and view the structure and data on various cells. We are going to use one worksheet to get a summary of each student’s grades. Since we are using one worksheet to register students, we will make sure that the worksheet used for registration supplies the students names to the worksheet used for summary grades. To see how it is done, we will practice only on the 6th Grade worksheet. 

3. Click the 6th Grade worksheet to activate it. 

4. In cell B8, type =CONCATENATE( 

5. Click the Student Registration sheet to make it active 

6. In the Student Registration sheet, click cell B8 (Brigitte) 

7. Type , 

8. Type “ Space “, 

9. Still in the Student Registration sheet, click cell D8 

10. Press Enter. 

11. You should be back in the 6th Grade worksheet, otherwise, click the 6th Grade worksheet to active it. 
Observe the result in cell B8. Click cell B8 and notice the CONCATENATE function in the Formula Bar: =CONCATENATE('Students Info'!B35," ",'Students Info'!D35) 

12. At this time, you could simply copy cell B8 to other cells but Microsoft Excel would not replicate the formatting (background) applied to other cells as they alternate. So, we are going to use a technique to copy both the formulas and the formatting of the cells. First we will apply the CONCATENATE function again in a cell that is formatted differently.
Still in the 6th Grade worksheet, click cell B9 and type =CONCATENATE( 

13. Click the Student Registration worksheet to make it active 

14. Click B9 

15. Type ,” Space “, 

16. Click cell D9 and press Enter. 

17. In the 6th Grade worksheet, select cells B8:B9 

18. Drag the Fill Handle of the selection down to B32 

19. Select cells B8:B9 again 

20. Drag their Fill Handle up to cell B6 

21. Press Ctrl + Home. Scroll up and down to check the result. 

22. Notice the last name of the first student, Song, and the first name of the 6th student, Bobby.
To check that the cells are linked, click the Student Registration worksheet to activate it. 

23. In cell D6, notice the last name of the first student, Song, and the first name of the 6th student, Bobby. In cell D6, type Singers. In cell B11, type Robert. Press Enter 

24. Click the 6th Grade worksheet and notice the name changed in cells D6 and B11. 

25. Click the Students Grades Summary worksheet and notice that it is empty at this time. 

26. Click the 6th Grade worksheet. Select cells B6:G32 

27. Click the Students Grades Summary worksheet to activate it 

28. Right-click cell B6 and click Paste Special…

29. From the Paste Special dialog, click Paste Link. Notice the values displayed. 

30. Click the 6th Grade worksheet to activate it. Select cells H6:J32 

31. Press Ctrl + C to copy the selected cells 

32. Click the Students Grades Summary sheet 

33. Right-click cell P6, click Paste Special… and click Paste Link 

34. To save your workbook, on the Standard toolbar, click Save

	


	Data Analysis With Charts

	


  

	Overview of Charts


	

	   

Introduction

Charts are used to analyze data graphically. Good created and formatted charts can help people and businesses make decisions based on the impact that their images provide to the users. Microsoft Excel is equipped with the Chart Wizard that allows you to create and format a chart to suit almost any scenario or need.

To create a chart, you must first decide where data is coming from. This is mostly done with information available on a worksheet. Formatted charts come in various flavors for diverse goals, ranging from columns to pies, from lines to surfaces, etc.

A chart is usually created on a two-dimension basis, which relates to data on columns and rows on a worksheet. Overall, once you have decided on the data source, you have a great deal of freedom on the design process. This means that you control what pieces of information will be available on the chart, how the chart will be displayed, whether to display the chart on the originating worksheet or a separate one.

A chart is made of different sections. The main area allows users to view the graphical display of data, the legend explains the meaning of various colors on the chart, the title indicates what the chart is used for. When designing one, the charts in Microsoft Excel are organized by types including columns, bars, lines, pie, etc.

When creating a chart, you will mainly be influenced by the kind of information you intend to analyze. Data that deals with scaled numbers such as monthly sales or student grades are suitable for column or bar charts. If your data is about percentage or fractions, you should use pie or doughnut charts. Microsoft Office ships with Microsoft Map, a special software product that allows you to create a mapped chart used to analyze data geographically, depending on the country or a region of the world.

Creating a Chart

When creating a chart, first find out what the chart will be used for, this allows you to get necessary data available. Once the originating data is available on a worksheet, select Microsoft Excel can recognize data format and act appropriately. To create a chart, you will primarily use the Chart Wizard which will take you step by step in creating the object. To start, select data intended to be analyzed, then on the Formatting toolbar, click the Chart Wizard button, and proceed. Charts come in different types for various purposes. 

Types of Charts

  

Column Charts

[image: image389]
A column chart can render a very effective result when analyzing data of the same category on a defined scale. The column chart emphasizes high and low values. It helps to compare items.

The classic column chart is made of flat bars that simply illustrate maximal, minimal, and in-between values. One of the options allows you to create a 3 dimensional look of the chart and further accentuate the colors and/or other graphic effects. To enhance an effective analysis, you can create a real 3-D chart that shows data and graphics in perspective.

[image: image390]Practical Learning: Create a Column Chart

1. Start Microsoft Excel

2. Open the Charts1 workbook

3. Click the Summary Sales worksheet to make it active

4. Select B5:E10

5. On the Standard toolbar, click the Chart Wizard button [image: image391]
6. From the Chart Wizard Step 1 of 4, make sure the Column category is selected in the Chart Type. In the Chart Sub-type list, click the chart in the 1st column, 1st row: Clustered column. Compares values across Categories. Click Next

[image: image392]
7. In the Chart Wizard Step 2 of 4, make sure the Columns radio button is selected. Click Next >

8. In the Chart Wizard Step 3 of 4, you don't need to change anything. Click Next.

9. In the Chart Wizard Step 4 of 4, make sure that the As Object In radio button is selected. Click Finish.

10. To reposition the chart, position the mouse on a white area on the chart, click, and drag to the right to move the chart in the lower right section of the screen
 
[image: image393]
11. Save the workbook 
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	Bar Charts

	


	Like the Column, the Bar chart is used to compare values of the same category on a common scale. This time, the chart is drawn horizontally. You create a Bar chart using the same process as the Column, except that you should select the Bar in step one.


	[image: image402]Practical Learning: Create a Bar Chart

	


	1. Click the Life Expectancy worksheet to make it active

2. Select cells C4:F10

3. On the Standard toolbar, click the Chart Wizard button [image: image403]
4. On the Chart Wizard Step 1 of 4, in the Chart Type list box, click Bar. In the Chart Sub-type list, click the chart on 1st column, 2nd row: Clustered Bar With 3-D Visual Effect
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5. Click Next

6. In the Chart Wizard Step 2 of 4, make sure the Columns radio button is selected. Click Next

7. In the Chart Wizard Step 3 of 4, click Next

8. In step 4 of 4, click Finish
 
[image: image405]
9. Save the workbook

 


	Line Charts

	


	A Line chart is used to analyze ups and downs of a tendency in a range of values. You can define it with one series of values where you will judge the evolution of an item over a period. When used with more than one series, this chart can be very helpful in comparing values of the same category over the same period. Fortunately, the Line chart can also be used to analyze values that don't share the same periodic variable. For example, you can use it to compare library attendance with regard to the real population number (which could be in hundreds of thousands or millions) with the number of people attending the library. In the latter situation, if the same axis are used to analyze, one category will almost disappear from the chart; the alternative is to separate their axis on the same chart. 

To create a Line chart, select the values in the category or categories that will be involved. After launching the Chart Wizard, select the Line and proceed. 


	[image: image406]Practical Learning: Create a Line Chart

	


	1. Click the Graphic Equation worksheet to make it active

2. Click cell B5 and type =(
3. Click cell B4

4. Type *
5. Click cell B4 again

6.  Type )-4 and press Enter

7. Click cell B5 to make it active. Drag its Fill Handle to cell N5. Notice the subsequent values following the defined function have been appended

8. Select cells B5:N5

9. On the main menu, click Insert -> Chart…

10. In step 1, in the Chart Type list, click Line. In the Chart Sub-type list, click the first button (1st column, 1st row). Click Next.

11. In step 2, in the Data Range property sheet, make sure that the Rows radio button is selected. Click the Series property page

12. Click the button on the empty Category (X) box [image: image407]
13. Select cells B4:N4

14. Click the button with red down pointing arrow on the Chart Wizard - Step 2 of 4 - Chart Source Data [image: image408]
 
[image: image409]
15. Click Next

16. In step 3 of 4, click the Titles property page and click the Chart Title text box

17. Type f(x) = x^2 - 4
18. Click the Legend property page

19. Click the Show Legend check box to remove its check box and click Next

20. In step 4 of 4, make sure that the As Object In radio button is selected. Click Finish.

 


	Pie and Doughnut Charts

	


	[image: image410]
	The Pie chart is used to show percentage and/or fraction values. You should choose it whenever your analysis involves values that altogether evaluate to a 100%, a 1, a 10, a 100, or a 1000 scale. 

To create a Pie chart, select the heading variables such as the age categories of library members, then select the range of values that representation the proportions such as the percentage of those who visit the library based on the previously selected variables.


	An alternative to the Pie is the Doughnut chart. Sometimes this one can be used as a better alternative because it can include more than one series.


	[image: image411]Practical Learning: Create a Column Chart

	


	1. Click the Age Structure sheet

2. Select cells C5:F5. Press and hold Ctrl, then select cells C9:F9

3. On the main menu, click Insert -> Chart…

4. In step 1 of 4, in the Chart Type, click Pie. In the Chart Sub-type, click the chart on 1st column, 1st row. Click Next

5. In step 2 of 4, make sure the Rows radio button is selected. Click Next

6. In step 3 of 4, click the Legend property page (it should be selected already). Make sure that the Show Legend radio button is selected. In the Placement section, click Bottom

7. Click the Data Labels property page. Click the Show Percent radio button

[image: image412]
8. Click Next

9. In step 4 of 4, make sure that the As Object In radio button is selected. Click Finish.


  

	The Cylinder, Cone, And Pyramid Charts

	


	The Cone, Cylinder, and Pyramid charts can be used in the same scenario as the column and bar. Their 3-D visual effect can enhance the overall analysis of data. 

The Cylinder chart creates long circular boxes of the same base on both ends. It can be enhanced with good formatted Fill Effects. This chart is suitable for industry, manufacturing analysis, and predictions.
	[image: image413]


	The cone is made of a circular base topped by a higher point. When used with various data, the higher values will have the complete cone while the lower values will share portion of the geometric figure. The cone chart should be used with values that can take advantage of its graphing dimensions.

The Pyramid chart resembles the cone chart with a difference on their respective base. Both are constructed the same and can be used in similar scenarios. When analyzing data for geographical purposes, the Pyramid chart can render very dramatic effects.


	[image: image414]Practical Learning: Creating a Cylindrical Chart

	


	1. Click the First Qtr Sales worksheet to make it active

2. Select cells B3:F6

3. On the Standard toolbar, click the Chart Wizard button

4. In step 1 of 4, in the Chart Type list, click Cone. In the Chart Sub-type list, click the chart in 1st column, 3rd row
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5. Click Next

6. In step 2 of 4, accept the default of Series In Rows. Click Next

7. In step 3 of 4, click the Legend property page. Make sure that the Show Legend check box is selected. In the Placement section, click Top

[image: image416]
8. Click Next

9. In step 4 of 4, accept all defaults and click Finish. 


  

	Chart Formatting 

	


  

	Introduction

	


	[image: image417]
	A chart created with all defaults settings usually accomplishes its purpose of helping to analyze data and figures, but the default features are set only as starting points. All the formatting and emphasis needs are left to you.

Besides the values and numbers on it, a chart is a graphic object whose characteristics can be enhanced to accentuate special important points of the whole process.

When you decide to create a chart, you should specify what kinds of numbers and values you are dealing with. 


	These numbers ought to be formatted appropriately. Fortunately, even after creating the chart, you can reformat your numbers with new settings and the chart will be updated, provided the numbers are similarly recognizable. You can also change the type most of the time and get a new and/or better result. Almost any feature on the chart can be changed or reformatted at will. 

Charts share most the characteristics of the graphic items that you have become familiar with. This allows you to change a chart background, to reformat the fonts on its axes, to enhance the color of its columns, bar, cones, etc through the Fill Effects feature. 

Whenever a chart is selected on the worksheet, a Chart Menu Bar replaces the regular main menu. When a chart is selected, the Chart toolbar allows you to reformat various characteristics related to the chart. Just like any combination of a menu and toolbar, the Chart Menu Bar and the Chart toolbar work together to offer all formatted features of the chart. 

It is also very useful to always have the Drawing toolbar handy. You can improve a chart's look by adding any of the usual drawing from shapes to special characters. 

 


	Change of Chart Type

	


	The Chart Wizard is equipped with various kinds of charts. In each category, different sub-types are used to accomplish a unique purpose. Although they share a lot of characteristics, some charts in the sub-type can tremendously change or alter the intended goal. You should know what options are available, and then act accordingly. 

Many charts can be changed from one kind to another, sometimes completely different. For example, you can change a chart from a flat column to a 3-D clustered. You can also change a chart from a bar to a cylinder, etc. 

To change a chart type, right-click on an empty area of the chart and click Chart Type from the menu. 


	[image: image418]Practical Learning: Changing a Chart Type

	


	1. Open the Charts2 workbook

2. Right-click on a white area on the chart and click Chart Type…

[image: image419]
3. From the Source Data dialog, click the chart on 1st column, 2nd row (Clustered column with a 3-D visual effect.).

4. Click OK.

5. Click the Life Expectancy worksheet to activate it.

6. Click the chart to make it active.

7. On the Chart toolbar, click the arrow of the Chart Type button and select 3-D Pyramid Chart.
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8. Click the Graphic Equation sheet to activate it.

9. Click the chart to select it.

10. On the main menu, click Chart ª Chart Type…11. From the Chart Type dialog, click the Custom Type property sheet. In the Chart Type list, click Colored Lines. Notice the preview in the Sample section.12. Still in the Chart Type dialog, click the Standard Type property sheet. In the Chart Type list, make sure Line is selected. In the Chart Sub-type list, click the chart in the 1st column, 2nd row. Click OK.


  

	Source Data

	


	More often, you will test data when creating your charts. Your experience with trials and errors can help to enhance the effects of your analysis. Therefore, you should know how to change all or parts of your chart. 

The chart keeps live track of the data used on it, this means your data is always updated to the minute if you change or delete it. Also, you can completely change the values that are controlling the chart. To change the source of data on a chart, right-click on a white area of the chart and click Source Data… If you want to, you can type the new range of data, but the safest way is to reselect data using the mouse. The Source Data property sheet is a modeless dialog; this allows you to select data behind the scenes while the dialog is opened. Once you have set the new range, click OK. 

If you observe the Summary Sales chart, you find that one of the sales people, Alex, is not selling a lot, at least as compared to other employees; this could be due to anything. Let's assume that Alex is a manager and is not directly involves with sales, except that some time to time, he helps other employees, that's could be why his sales are low. If then he is not a sales person, we can just remove him from the chart and analyze the figures of those who have that profession. 


	[image: image421]Practical Learning: Create a Column Chart

	


	1. Still in the Chart2 workbook, click the Summary Sales worksheet.

2. Click the chart to activate it.

3. Right-click on a white area on the chart and click Source Data…

4. From the Source Data dialog, click the button on the right side of the Data Range edit box.

5. Select cells B5:E7

6. Press and hold Ctrl. Select cells B10:E10. Release Ctrl.
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7. Click the button just under the Close button to get back to the Source Data dialog.

8. Click OK


	MS Excel Examples: Net Price
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	Introduction
This small example shows how to perform a simple operation of calculating the amount of tax retrieved from a sale item and the net price sold.

The marked price, the price presented on an item, is in currency value. It this example, it would be $120.95

The tax rate is expressed as a percentage value. An example would be 5.75%

The computer used to evaluate the price use a formula such as:

Tax Amount = Marked Price / Tax Rate

The net price, the actual price a customer should pay, is calculated as:

Net Price = Marked Price + Tax Amount

In this exercise, we will simulate such a calculation 

Practical Learning: Performing the Calculation

1. Start Microsoft Excel 

2. In cell B2, type Net Price Calculation 

3. In cell B3, type Marked Price: 

4. In cell B4, type Tax Rate: 

5. In cell B5, type Tax Amount: 

6. In cell B6, type Net Price: 

7. In cell D3, type 0.00 

8. In cell D4, type 5.75% 

9. In cell D5, type =D3*D4 

10. In cell D6, type =D3+D5 

11. To test the application, change the value of cell D3 and press Enter 
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